summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c0708f1cd13..9bbc8bf80989 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
pkgname=cen64-git
-pkgver=20160127
+pkgver=r677.80e43ef
pkgrel=1
+epoch=1
pkgdesc="Cycle-accurate Nintendo 64 emulator"
arch=('i686' 'x86_64')
url="http://www.cen64.com/"
@@ -13,15 +14,11 @@ sha256sums=('SKIP')
pkgver() {
cd cen64
- git log -1 --format="%cd" --date=short | sed 's|-||g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
mkdir -p build
-
- # Build with different sampling frequency
- # See: http://forums.cen64.com/viewtopic.php?f=6&t=186&start=20#p2085
- sed -i 's/44100/31985/g' cen64/ai/context.c cen64/ai/controller.c
}
build() {
@@ -30,14 +27,14 @@ build() {
_arch_support="SSSE3"
# Enable busy-wait-detection for better performance
- _wait_loop="ON"
+ _detect_wait_loops="ON"
cd build
cmake ../cen64 \
-DCMAKE_BUILD_TYPE=Release \
-DCEN64_ARCH_SUPPORT=${_arch_support} \
- -DVR4300_BUSY_WAIT_DETECTION=${_wait_loops}
+ -DVR4300_BUSY_WAIT_DETECTION=${_detect_wait_loops}
make
}