summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf49e44adbd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+#Maintainer: Oleksandr Natalenko <oleksandr@natalenko.name>
+#Former contributor: Matt Monaco <net 0x01b dgbaley27>
+#Former maintainer: Gui||aume <michaudg at gmail.com>
+
+pkgname=ceph-deploy
+pkgver=1.5.28
+pkgrel=1
+arch=(any)
+pkgdesc="Deploy Ceph with minimal infrastructure, using just SSH access"
+url=http://ceph.com
+license=(custom)
+source=(git://github.com/ceph/ceph-deploy.git#tag=v$pkgver)
+sha256sums=(SKIP)
+depends=(python2 python2-pushy)
+makedepends=(git python2-setuptools)
+
+package() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}