summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c378bf5e0c5a..cff28e5fe4de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
pkgname='certbot-dns-vultr'
pkgver='20190506'
_commit='5acb7e2b6d66f21decb3a37ed0d7ec808eefe844'
-pkgrel='3'
+pkgrel='4'
pkgdesc='Cerbot hooks for Vultr DNS'
arch=('any')
url="https://github.com/oefd/$pkgname"
license=('MIT')
-depends=('python' 'python-certifi' 'python-chardet' 'python-idna' 'python-requests' 'python-urllib3' 'certbot')
-source=("https://raw.githubusercontent.com/oefd/$pkgname/$_commit/vultr-hook.py")
-sha256sums=('43c495691b0eb56d11f1d63beb6ecd5d24c8b7c4919af1282db1d3269c551e0f')
+depends=('certbot' 'python' 'python-certifi' 'python-chardet' 'python-idna' 'python-requests' 'python-urllib3')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$_commit.tar.gz")
+sha256sums=('afd6998a24c52d87f95610de1da8038e9b6701b0532ba0e40d50d17e8d2ddcfb')
package() {
- install -Dm755 "$srcdir/vultr-hook.py" "$pkgdir/usr/bin/$pkgname"
+ cd "$srcdir/$pkgname-$_commit/"
+ install -Dm755 'vultr-hook.py' "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}