summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5708140b776..17fc0f4ef52d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Kat Witten <turtlewit@live.com>
pkgname=cglm
-pkgver=0.6.1
+pkgver=0.7.0
pkgrel=1
pkgdesc="OpenGL Mathematics (glm) for C"
arch=('x86_64')
@@ -8,7 +8,7 @@ url="https://github.com/recp/cglm"
license=('MIT')
depends=('glibc')
source=("$pkgname-$pkgver.tar.gz::https://github.com/recp/cglm/archive/v$pkgver.tar.gz")
-md5sums=('7cb2806f8ec78bfdbfa662cd7e27f003')
+md5sums=('a6f556e6dd1804d4bcb0cba3c848fe9f')
build() {
cd "$pkgname-$pkgver"
@@ -20,7 +20,8 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
- install -d "$pkgdir/usr/share/licenses/cglm"
+ cp -a include/cglm/* "$pkgdir/usr/include/cglm/" # work around missing header file not copied with make install
+ install -d "$pkgdir/usr/share/licenses/cglm/"
install LICENSE "$pkgdir/usr/share/licenses/cglm/"
install -d "$pkgdir/usr/lib/pkgconfig/"
install cglm.pc "$pkgdir/usr/lib/pkgconfig/"