summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cddfe06cc1a..d6464e320248 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=charybdis
pkgname=charybdis-git
-pkgver=latest
+pkgver=charybdis.3.5.0.r945.g5a77522
pkgrel=1
pkgdesc='A highly scalable IRCv3-compliant IRCd (development version)'
url='http://atheme.org/project/charybdis'
license=('GPL2')
options=('!strip')
install=charybdis.install
-source=('git+https://github.com/atheme/charybdis.git'
+source=('git+https://github.com/charybdis-ircd/charybdis'
'charybdis.service'
'charybdis.tmpfiles')
sha256sums=('SKIP'
@@ -27,12 +27,15 @@ pkgver() {
cd "${srcdir}/${_pkgname}"
# Get the version number.
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${srcdir}/${_pkgname}"
+ # Set up the build.
+ ./autogen.sh
+
# Configure the build.
./configure \
--prefix=/usr \