summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d947dfb5678
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexandr Skurikhin <askurihin@gmail.com>
+# Maintainer: Robert Orzanna <orschiro@gmail.com>
+# Maintainer: Quan Guo < guotsuan@gmail.com>
+
+pkgname=cheat-git
+pkgver=2.0.9.30.g7eb405d
+pkgrel=1
+pkgdesc="Cheat allows you to create and view interactive cheatsheets on the command-line"
+arch=('any')
+license=('GPL3')
+url="https://github.com/chrisallenlane/cheat"
+depends=('python2' 'python2-docopt')
+optdepends=('python-pygments')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/chrisallenlane/cheat.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $pkgname
+ git describe | sed 's/^v//;s/-/./g'
+}
+
+package(){
+ cd "$pkgname"
+ python2 setup.py install --root=$pkgdir
+}