summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02ae899c29a7..92db21940d85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,27 @@
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
pkgname=checkpolicy
-pkgver=2.6
+pkgver=2.7
pkgrel=1
pkgdesc="SELinux policy compiler"
arch=('i686' 'x86_64')
url='http://userspace.selinuxproject.org'
-license=('GPL')
+license=('GPL2')
groups=('selinux')
-depends=('libsepol>=2.5' 'libselinux>=2.5')
+makedepends=('libsepol>=2.7')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-options=(!emptydirs)
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('0bebd18688ca8027b1b3b4ff1532c0626f1fe49883ae6cb74d9d385940e74157')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('5413479f1dcde866c19896b4dbfec315d822aa431606e1d03c944408984c3201')
build() {
cd "${pkgname}-${pkgver}"
make
}
-package(){
+package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" LIBSEPOLA=/usr/lib/libsepol.a install
install -m 0755 test/dismod "${pkgdir}"/usr/bin/sedismod
install -m 0755 test/dispol "${pkgdir}"/usr/bin/sedispol
}