summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 24 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 711dfb800f71..fc7387bc21e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,50 @@
# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
+# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
pkgname=cherrytree
-pkgver=0.99.27
+pkgver=0.99.28
pkgrel=1
pkgdesc="Hierarchical note-taking application"
arch=('x86_64')
url="https://www.giuspen.com/${pkgname}/"
license=('GPL3')
-depends=('gspell'
+depends=('fmt'
+ 'gspell'
'gtksourceviewmm'
'libxml++2.6'
'uchardet')
+optdepends=('xorg-xhost: allow chroot access to X server for running tests')
makedepends=('cmake'
- 'python')
-source=(https://www.giuspen.com/software/${pkgname}_${pkgver}.tar.xz)
-sha256sums=('1c10020eef6e222bbdaa87b9d15d85b703380aba4727a2fbd0f09f8cc353c606')
+ 'python'
+ 'spdlog')
+source=(https://www.giuspen.com/software/${pkgname}_${pkgver}.tar.xz{,.asc})
+sha256sums=('54d246dcd15ce699d6260a9322289a5fcba40fa2490cfea68dc394541c0d74c9'
+ 'SKIP')
+validpgpkeys=('C7BF38CE0BD442C2369AA984049128A20CE0648D') # Giuseppe Penone <giuspen [at] gmail [dot] com>
-prepare() {
- # Fix automatic optimisation flag override
- sed -i 's/-O3/-O2/' "${pkgname}_${pkgver}/CMakeLists.txt"
-}
-
-# Remove GMOCK and TESTING options to build and run tests
-# If utilising tests, make sure cherrytree is NOT already running!
build() {
cmake \
-B "${pkgname}_${pkgver}/build" \
-S "${pkgname}_${pkgver}" \
-DBUILD_GMOCK:BOOL='OFF' \
-DBUILD_TESTING:BOOL='OFF' \
- -DINSTALL_GTEST:BOOL='OFF' \
-Wno-dev
make -C "${pkgname}_${pkgver}/build"
}
+# NOTE: In order to run tests in a clean chroot, you must allow it access your X server:
+# xhost +local:
+# https://wiki.archlinux.org/index.php/chroot#Run_graphical_applications_from_chroot
+#check() {
+# export DISPLAY=:0
+# cmake \
+# -B "${pkgname}_${pkgver}/test-build" \
+# -S "${pkgname}_${pkgver}" \
+# -DINSTALL_GTEST:BOOL='OFF' \
+# -Wno-dev
+# make -C "${pkgname}_${pkgver}/test-build/tests"
+#}
+
package() {
make -C "${pkgname}_${pkgver}/build" DESTDIR="${pkgdir}" install
}