summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a74f70d9ec78..da87986d5dae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=chipmunk
-pkgver=6.0.2
+pkgver=6.0.1
pkgrel=1
pkgdesc="A high-performance 2D rigid body physics library"
arch=('i686' 'x86_64')
@@ -11,13 +11,11 @@ url="http://code.google.com/p/chipmunk-physics/"
license=('MIT')
depends=('mesa' 'freeglut' 'libxmu' 'libxext')
makedepends=('cmake')
-source=(http://files.slembcke.net/chipmunk/release/Chipmunk-${pkgver%%.*}.x/Chipmunk-$pkgver.tgz chipmunk-6.0.2-ffi_duplicate_definition.patch)
+source=(http://files.slembcke.net/chipmunk/release/Chipmunk-${pkgver%%.*}.x/Chipmunk-$pkgver.tgz)
build() {
cd "$srcdir/Chipmunk-$pkgver"
- patch -p0 -i "$srcdir/chipmunk-6.0.2-ffi_duplicate_definition.patch"
- # Fix wrong lib version number
- sed -i 's|6.0.1|6.0.2|' src/CMakeLists.txt
+ sed -i '/MAKE_PROPERTIES_REF(cpShape, IsSensor);/d' include/chipmunk/chipmunk_ffi.h
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_DEMOS=OFF -DCMAKE_C_FLAGS="-DCHIPMUNK_FFI" .
make clean
make
@@ -29,5 +27,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums=('c1b7917e7ce2160fa2d5305a451b152c'
- '5260d3d4e86cde4859a8fc3baccfde09')
+md5sums=('ba7ed00e32176152040801ad0b0c44f3')