summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 22 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc9eff7fcba2..71a3f4a97a46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,32 @@
-# Maintainer: brent s. <bts[at]square-r00t[dot]net>
-validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
-# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
-# News updates for packages can be followed at https://devblog.square-r00t.net
+# Maintainer: Qontinuum <qontinuum@artixlinux.org>
+# Contributor: brent s. <bts[at]square-r00t[dot]net>
+
pkgname=chkrootkit
-pkgver=0.54
+pkgver=0.58b
pkgrel=1
pkgdesc="Locally checks for signs of a rootkit"
arch=('x86_64')
url="http://www.chkrootkit.org/"
-license=( 'CUSTOM' )
-install=
-changelog=
-noextract=()
-# Is this necessary for ifpromisc?
-#depends=('net-tools')
+license=('CUSTOM')
optdepends=('tiger: a wrapper for chkrootkit')
-source=("ftp://ftp.pangeia.com.br/pub/seg/pac/${pkgname}-${pkgver}.tar.gz"
- "${pkgname}.launcher"
- "${pkgname}-${pkgver}.tar.gz.sig"
- "${pkgname}.launcher.sig")
-sha512sums=('fe8955ac33abaabf304f5580b6f12929f8bf02329ab442380eaa6298440cf1cb0eee2db8e5667ea7d78b89ee2bceb82c10ebb732a71d6bcdda9400569cd587fd'
- 'c7a28d6313dc48cc17a0850e2816b9b17a8b0bdf435c3f75fbd4deedf740067de8e58b38d488945561bf9c3ad8bb03adc8e4a5a1da63775bce1afdcf49fd83ba'
- 'SKIP'
- 'SKIP')
+source=("ftp://ftp.chkrootkit.org/pub/seg/pac/$pkgname-$pkgver.tar.gz")
+sha512sums=('50829446aa5a320ef3aa678c7bbc03ba2ebc14dca3b4c1f312fb46d3d8206345628d2e94b99cfea33e0d3971afbc025dbd387fb32c4e1135a7466c20eb3afab2')
+
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make sense
+ make -C "$srcdir/$pkgname-$pkgver"
}
+
package() {
- for f in check_wtmpx chkdirs chklastlog chkproc chkrootkit chkutmp chkwtmp ifpromisc strings-static;
- do
- install -D -m755 ${srcdir}/${pkgname}-${pkgver}/${f} ${pkgdir}/usr/lib/${pkgname}/${f}
- done
- install -D -m755 ${srcdir}/${pkgname}.launcher ${pkgdir}/usr/bin/${pkgname}
- install -D -m644 ${srcdir}/${pkgname}-${pkgver}/COPYRIGHT ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- for f in ACKNOWLEDGMENTS README; # sic
- do
- install -D -m644 ${srcdir}/${pkgname}-${pkgver}/${f} ${pkgdir}/usr/share/doc/${pkgname}/${f}
- done
+ cd "$srcdir/$pkgname-$pkgver"
+
+ for f in check_wtmpx chkdirs chklastlog chkproc chkrootkit chkutmp chkwtmp ifpromisc strings-static; do
+ install -Dvm755 -t "$pkgdir/usr/lib/$pkgname" "$f"
+ done
+
+ install -Dvm644 -t "$pkgdir/usr/share/licenses/$pkgname" COPYRIGHT
+ install -Dvm644 -t "$pkgdir/usr/share/doc/$pkgname" ACKNOWLEDGMENTS
+ install -Dvm644 -t "$pkgdir/usr/share/doc/$pkgname" README
+
+ install -dvm 755 "$pkgdir/usr/bin"
+ ln -vs "../lib/$pkgname/chkrootkit" "$pkgdir/usr/bin/chkrootkit"
}