summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2360ab6eecb2..cea386e32e5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,12 @@ makedepends=('git' 'go-pie')
source=("git+https://gitlab.com/chacas0/chksum#branch=master")
sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
build() {
cd "$srcdir/chksum"
go build \