summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a32b0c48ca45..23389b082bf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
-# Maintainer: JunYoung Gwak <aur@jgwak.com>
-
+# Maintainer: Raymond Li <aur@raymond.li>
+# Contributor: Robert Walaski <robert@walaski.cz>
+# Contributor: JunYoung Gwak <aur@jgwak.com>
+# Contributor: relrel <relrelbachar@gmail.com>
_pkgname=chromedriver
pkgname=${_pkgname}-beta
-pkgver=80.0.3987.16
+pkgver=125.0.6422.41
pkgrel=1
-pkgdesc="Standalone server which implements WebDriver's wire protocol (for google-chrome-beta)"
+pkgdesc="Standalone server that implements the W3C WebDriver standard (for google-chrome-beta)"
arch=('x86_64')
-url="https://sites.google.com/a/chromium.org/chromedriver/"
-license=('Apache')
-conflicts=('chromium')
-depends=('libpng' 'gconf')
-optdepends=('google-chrome-beta')
+url="https://chromedriver.chromium.org/"
+license=('BSD')
+depends=(alsa-lib gtk3 libcups libxss libxtst nss xdg-utils)
+optdepends=(google-chrome-beta)
provides=(${_pkgname})
-md5sums=('e1a87e90a683689079a6759f82106839')
-
-source=("${_pkgname}_${pkgver}_linux64.zip::http://chromedriver.storage.googleapis.com/${pkgver}/${_pkgname}_linux64.zip")
+conflicts=(chromium)
+source=("${_pkgname}_${pkgver}_linux64.zip::https://storage.googleapis.com/chrome-for-testing-public/${pkgver}/linux64/${_pkgname}-linux64.zip")
+sha512sums=('826a28b2ff766272b2b88732fb168fb8795aa6fa04f974d3eb5c60d9a13e18e6527fd6540bf2dbebb862c92c97bf66a41a9b5080e4dd653c33928ca6654f70a1')
package() {
- mkdir -p "$pkgdir/usr/bin/"
- install -D -m 755 "$srcdir/$_pkgname" "$pkgdir/usr/bin/"
+ install -Dm755 -t "$pkgdir/usr/bin/" "$srcdir/${_pkgname}-linux64/${_pkgname}"
}