summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4e38ef315a1..adf742741400 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _enable_vaapi=0 # Patch for VAAPI HW acceleration NOTE: don't work in som
## -- Package and components information -- ##
##############################################
pkgname=chromium-dev
-pkgver=56.0.2897.0
+pkgver=56.0.2914.3
_launcher_ver=3
pkgrel=1
pkgdesc="The open-source project behind Google Chrome (Dev Channel)"
@@ -84,10 +84,9 @@ source=( #"https://gsdview.appspot.com/chromium-browser-official/chromium-${pkgv
# Patch form Gentoo
'https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-system-ffmpeg-r4.patch'
'https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-system-jinja-r14.patch'
- 'https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-gn-r8.patch'
# Misc Patches
- "https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/0507ec8f882295901bc33dba58260b6f87b4dfd8/debian/patches/enable_vaapi_on_linux.diff"
- 'https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/0507ec8f882295901bc33dba58260b6f87b4dfd8/debian/patches/specify-max-resolution.patch'
+ "enable_vaapi_on_linux_${pkgver}.diff::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/65ffd5a596f747d4aacdb93a68593ee6e40b36cc/debian/patches/enable_vaapi_on_linux.diff"
+ "specify-max-resolution_${pkgver}.patch::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/65ffd5a596f747d4aacdb93a68593ee6e40b36cc/debian/patches/specify-max-resolution.patch"
'minizip.patch'
'unset-madv_free.patch'
# Patch from crbug (chromium bugtracker)
@@ -101,9 +100,8 @@ sha256sums=( #"$(curl -sL https://gsdview.appspot.com/chromium-browser-official/
# Patch form Gentoo
'e3c474dbf3822a0be50695683bd8a2c9dfc82d41c1524a20b4581883c0c88986'
'a9cb08fbac8ffcf6371edd7ab67833efd42c5b92938f1e2e7922d1d22d226db8'
- '8abe0b63202f78304ab50f3f23df165453171b91f4e9ebeabe9ec9e78345b937'
# Misc Patches
- 'd45827fe84a3fa3d55da7f9c3241f9b5b4d309b4d16e61cc121be3c8aa92553b'
+ '33f3bf254f57fc9ee093c914cd41e5c3e74cd681b43c533d3fb173a08c8d44a9'
'025042ac038ea5fdaabc91e67b13a410d2cacd9afc2d74f89b36fdf2388d4afc'
'95ba939b9372e533ecbcc9ca034f3e9fc6621d3bddabb57c4d092ea69fa6c840'
'3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
@@ -229,6 +227,7 @@ _keeplibs=('base/third_party/dmg_fp'
'third_party/google_input_tools/third_party/closure_library/third_party/closure'
'third_party/hunspell'
'third_party/iccjpeg'
+ 'third_party/inspector_protocol'
'third_party/jstemplate'
'third_party/khronos'
'third_party/leveldatabase'
@@ -287,6 +286,7 @@ _keeplibs=('base/third_party/dmg_fp'
'third_party/zlib/google'
'url/third_party/mozilla'
'v8/src/third_party/valgrind'
+ 'v8/third_party/inspector_protocol'
)
# Set build flags.
@@ -382,12 +382,11 @@ prepare() {
# Patch sources from Gentoo.
patch -p1 -i "${srcdir}/chromium-system-ffmpeg-r4.patch"
patch -p1 -i "${srcdir}/chromium-system-jinja-r14.patch"
- patch -p1 -i "${srcdir}/chromium-gn-r8.patch"
# Misc Patches:
if [ "${_enable_vaapi}" = 1 ]; then
- patch -p1 -i "${srcdir}/enable_vaapi_on_linux.diff"
- patch -p1 -i "${srcdir}/specify-max-resolution.patch"
+ patch -p1 -i "${srcdir}/enable_vaapi_on_linux_${pkgver}.diff"
+ patch -p1 -i "${srcdir}/specify-max-resolution_${pkgver}.patch"
fi
# Fix paths.