summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 22 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96ed34ec3e3b..b5eb38edb63f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-ozone
-pkgver=72.0.3626.121
+pkgver=73.0.3683.75
pkgrel=1
_launcher_ver=6
-_release_sha=e9e63ab0ce7758849cbb7e8f9a62afcb239e05da
-_igalia_sha=ceadbfcbc9178b88485b8fff82da4d4fe5673af8
+_release_sha=5fe448ea2471245e64adf805d93b358dd9478fa2
+_igalia_sha=9acc2112d690af6caf4c5b8d4152b5724a760639
pkgdesc="Chromium built with patches for wayland support via Ozone"
arch=('x86_64')
url="https://www.chromium.org/Home"
@@ -30,28 +30,26 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-drirc-disable-10bpc-color-configs.conf
chromium-system-icu.patch
- chromium-webrtc-missing-header.patch
chromium-vaapi.patch
- chromium-vaapi-relax-the-version-check-for-VA-API.patch
- chromium-enable-mojo-video-decoders-by-default.patch
- chromium-vaapi-fix-the-VA_CHECK_VERSION.patch
+ chromium-color_utils-use-std-sqrt.patch
+ chromium-media-fix-build-with-libstdc++.patch
+ chromium-avoid-log-flooding-in-GLSurfacePresentationHelper.patch
chromium-widevine.patch
chromium-skia-harmony.patch
chromium-ozone-wayland.patch::https://github.com/mirror/chromium/compare/${_release_sha}...Igalia:${_igalia_sha}.patch
chromium-algorithm-header.patch::https://github.com/chromium/chromium/commit/6c0254a78043e32441dbc2e6d4893590dd0d1953.patch
chromium-vaapi-build.patch::https://github.com/Igalia/chromium/commit/cdb2e638d4488936c80a2c1b506eecf95ffbee02.patch)
-sha256sums=('4c1e554ab606eab328e77f5a92d8244b26a10ffd15d7986d30eab95f37adbc1f'
+sha256sums=('8304810626c69c296b3262844e20052e7476280b634c525a711a7f6c0e3dd57c'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
'e2d284311f49c529ea45083438a768db390bde52949995534034d2a814beab89'
- '63cbed7d7af327c17878a2066c303f106ff08636372721845131f7ff13d87b44'
'e87ede45edf39ac19e56ac1ae49c9d1f5f5130e5838bcbb4c3d4fb16e55575c0'
- '07fcf5d25114c7335582f117090b5e0bd148aca69044d4fe25c66b4c52dcd2a6'
- '669a9ad4773d182a06ee729008a60aeadddae92f1a0077b3811e11f292c8d4ff'
- '0bd750255163bfb1bedaf97c1cdb313f42bd9e6e52243c6e68494b6e0ffb84bf'
+ 'b3b6f5147d519c586cbdaf3b227dd1719676fa3a65edd6f08989087afd287afa'
+ 'f51fe91427d8638c5551746d2ec7de99e8059dd76889cfeaee8ca3d8fed62265'
+ 'f2b12ccf83a8e0adda4a87ae5c983df5e092ccf1f9a6f2e05799ce4d451dbda1'
'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
'5887f78b55c4ecbbcba5930f3f0bb7bc0117c2a41c2f761805fcf7f46f1ca2b3'
- '0c1054d95c3275355becea79790a24fcca60912b904b3efc8a961dd73eed4091'
+ 'fcb58a760e2dc6c4b2746c12832edd8dfe54dc37113e01b3b5bc108fbeec4c8a'
'5662e88f7bd1a36848d3ecf166e9a282b7fa3858bd1261d582c97654af0c1348'
'4ed0ac74fef8b63fa5dfd0de02a02cc4a7667898a90ec5365651645777934c14')
@@ -67,7 +65,7 @@ declare -gA _system_libs=(
[libdrm]=
[libjpeg]=libjpeg
#[libpng]=libpng # https://crbug.com/752403#c10
- #[libvpx]=libvpx # needs unreleased libvpx
+ [libvpx]=libvpx
[libwebp]=libwebp
[libxml]=libxml2
[libxslt]=libxslt
@@ -103,11 +101,17 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/libxml_utils.cc
+ # https://crbug.com/819294#c88
+ patch -Np1 -i ../chromium-color_utils-use-std-sqrt.patch
+
+ # https://crbug.com/931373
+ patch -d media -Np1 -i ../../chromium-media-fix-build-with-libstdc++.patch
+
+ # https://crbug.com/879929
+ patch -Np1 -i ../chromium-avoid-log-flooding-in-GLSurfacePresentationHelper.patch
+
# Enable VAAPI on Linux
# patch -Np1 -i ../chromium-vaapi.patch
- # patch -Np1 -i ../chromium-vaapi-relax-the-version-check-for-VA-API.patch
- # patch -Np1 -i ../chromium-enable-mojo-video-decoders-by-default.patch
- # patch -Np1 -i ../chromium-vaapi-fix-the-VA_CHECK_VERSION.patch
# Load Widevine CDM if available
patch -Np1 -i ../chromium-widevine.patch
@@ -115,9 +119,6 @@ prepare() {
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
- # https://webrtc.googlesource.com/src.git/+/3e70781361ed
- patch -Np0 -i ../chromium-webrtc-missing-header.patch
-
# https://bugs.gentoo.org/661880#c21
patch -Np1 -i ../chromium-system-icu.patch
@@ -132,6 +133,7 @@ prepare() {
# Remove compiler flags not supported by our system clang
sed -i \
+ -e '/"-fsplit-lto-unit"/d' \
-e '/"-Wno-defaulted-function-deleted"/d' \
build/config/compiler/BUILD.gn