summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ade636419e2..9abd594a0cda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=chromium-no-extras
pkgver=89.0.4389.72
-pkgrel=1
+pkgrel=2
_pkgname=chromium
_launcher_ver=7
_gcc_patchset=6
@@ -20,7 +20,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs'
- 'java-runtime-headless' 'python2' 'python2-setuptools')
+ 'java-runtime-headless' 'python2' 'python2-setuptools')
optdepends=(
'kdialog: needed for file dialogs in KDE'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
@@ -29,6 +29,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkg
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
add-dependency-on-opus-in-webcodecs.patch
+ don-t-crash-on-reentrant-RunMoveLoop-call.patch
add-ctime-for-std-time.patch
chromium-glibc-2.33.patch
use-oauth2-client-switches-as-default.patch)
@@ -36,6 +37,7 @@ sha256sums=('946a0b65aad10e0f77a539103892099b7238310c733f25b41d58b76f6ac0bc4f'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
'359d2847e775d8cf6f4e0b12c94c8f2718f0fd562427859c596ce1c3711dbd8e'
'b86b11de8db438c47f0a84c7956740f648d21035f4ee46bfbd50c3348d369121'
+ '615f5fefc94da605957edb34b6c000f32953fb5ff6ffb321f062dab8e0fef9d3'
'102e0c976c0d7fd1fbe2f2978ec621499a97b62457b3fde4daf84f026d1a53a7'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
@@ -97,6 +99,7 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../add-dependency-on-opus-in-webcodecs.patch
+ patch -Np1 -i ../don-t-crash-on-reentrant-RunMoveLoop-call.patch
patch -Np1 -i ../add-ctime-for-std-time.patch
# Fixes for building with libstdc++ instead of libc++
@@ -159,7 +162,7 @@ build() {
'enable_hangout_services_extension=false'
'enable_widevine=false'
'enable_nacl=false'
- "google_api_key=\"${_google_api_key}\""
+ "google_api_key=\"$_google_api_key\""
# from ArchARM to build with distcc, uncomment if you build with distcc
#'is_cfi=false'
#'use_gold=false'