summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 5 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99df2a105caf..cc7c6c5ac7d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,10 @@
pkgname=chromium-no-extras
_pkgname=chromium
-pkgver=102.0.5005.115
+pkgver=103.0.5060.53
pkgrel=1
_launcher_ver=8
-_gcc_patchset=5
+_gcc_patchset=4
pkgdesc="Chromium without hangout services, widevine, pipewire, or chromedriver"
arch=('x86_64')
url="https://www.chromium.org/Home"
@@ -33,20 +33,16 @@ options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- iwyu-add-utility-for-std-exchange.patch
enable-GlobalMediaControlsCastStartStop.patch
roll-src-third_party-ffmpeg.patch
- chromium-libxml-unbundle.patch
sql-make-VirtualCursor-standard-layout-type.patch
remove-no-opaque-pointers-flag.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('301d40e5373b6dad9bc6aeb6898116d1f7dd2d0589ed18e108c56e2290df47e6'
+sha256sums=('0ecbae14670506da90c8bf744f83f52a64a5fff0765c2e2e066b0e68b805b101'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
- '53de0f936fd571e578ba2fbf348c8741116cdcceac3ea6fae5008d8f054a7698'
- '6f666ef0acb08704ca58cc0d5e97e7ce64d8fea51042e593adae1ce15a61231c'
+ 'fed11a8987d9f9baa04457fb114f8f7fdb800300a3780927020865bcc43e4f52'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
'30df59a9e2d95dcb720357ec4a83d9be51e59cc5551365da4c0073e68ccdec44'
- 'fd3bf124aacc45f2d0a4f1dd86303fa7f2a3d4f4eeaf33854631d6cb39e12485'
'b94b2e88f63cfb7087486508b8139599c89f96d7a4181c61fec4b4e250ca327a'
'00c16ce83ea4ca924a50fa0cfc2b2a4d744c722f363b065323e6ba0fcbac45a5'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
@@ -107,9 +103,6 @@ prepare() {
# Remove '-Xclang -no-opaque-pointers' flag not supported by our clang
patch -Np1 -i ../remove-no-opaque-pointers-flag.patch
- # Upstream fixes
- patch -Np1 -i ../iwyu-add-utility-for-std-exchange.patch
-
# Revert kGlobalMediaControlsCastStartStop enabled by default
# https://crbug.com/1314342
patch -Rp1 -F3 -i ../enable-GlobalMediaControlsCastStartStop.patch
@@ -118,15 +111,11 @@ prepare() {
# https://crbug.com/1325301
patch -Rp1 -i ../roll-src-third_party-ffmpeg.patch
- # https://chromium-review.googlesource.com/c/chromium/src/+/3488058
- patch -Np1 -i ../chromium-libxml-unbundle.patch
-
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../patches/chromium-102-fenced_frame_utils-include.patch
- patch -Np1 -i ../patches/chromium-102-regex_pattern-array.patch
+ #patch -Np1 -i ../patches/
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin