summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3eb1840cba0e..c3e10ce6c187 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,17 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
# optionally modify to fit your specific hardware
-#export CFLAGS+=" -march=znver3 -mtune=znver3"
-#export CXXFLAGS="${CFLAGS}"
-#PKGEXT='.pkg.tar'
+
+# hacky way to determine subarch
+_cpu=$(gcc -c -Q -march=native --help=target | grep ' -march=' | awk '{ print $2}')
+
+export CFLAGS+=" -march=$_cpu -mtune=$_cpu"
+export CXXFLAGS+=" -march=$_cpu -mtune=$_cpu"
+PKGEXT='.pkg.tar'
pkgname=chromium-no-extras
_pkgname=chromium
-pkgver=108.0.5359.94
+pkgver=108.0.5359.98
pkgrel=1
_launcher_ver=8
_gcc_patchset=2
@@ -35,15 +39,19 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
+ chromium-icu72.patch
+ v8-enhance-Date-parser-to-take-Unicode-SPACE.patch
REVERT-roll-src-third_party-ffmpeg-m102.patch
REVERT-roll-src-third_party-ffmpeg-m106.patch
disable-GlobalMediaControlsCastStartStop.patch
angle-wayland-include-protocol.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('0607518481a8a5b993fb371eec544f7d20e43c2eb706ca7bf40ef584496cb6fe'
+sha256sums=('60b6137971e3cb2947477f654491ed4f517ab88ea2807fa3b89fcce34b83561e'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'40ef8af65e78901bb8554eddbbb5ebc55c0b8e7927f6ca51b2a353d1c7c50652'
'9015b9d6d5b4c1e7248d6477a4b4b6bd6a3ebdc57225d2d8efcd79fc61790716'
+ 'dabb5ab204b63be73d3c5c8b7c1fa74053105a285852ba3bbc4fb77646608572'
+ 'b83406a881d66627757d9cbc05e345cbb2bd395a48b6d4c970e5e1cb3f6ed454'
'30df59a9e2d95dcb720357ec4a83d9be51e59cc5551365da4c0073e68ccdec44'
'4c12d31d020799d31355faa7d1fe2a5a807f7458e7f0c374adf55edb37032152'
'7f3b1b22d6a271431c1f9fc92b6eb49c6d80b8b3f868bdee07a6a1a16630a302'
@@ -111,6 +119,8 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
+ patch -Np1 -i ../chromium-icu72.patch
+ patch -Np1 -d v8 <../v8-enhance-Date-parser-to-take-Unicode-SPACE.patch
# Revert ffmpeg roll requiring new channel layout API support
# https://crbug.com/1325301