summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 31 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cd86f336c08..89d2900cd5d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-no-extras
+pkgver=80.0.3987.87
+pkgrel=1
_pkgname=chromium
-pkgver=79.0.3945.130
-pkgrel=2
_launcher_ver=6
pkgdesc="Chromium without hangout services, widevine, pipewire, or chromedriver"
arch=('x86_64')
@@ -17,9 +17,9 @@ provides=(chromium=$pkgver)
conflicts=(chromium)
depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib'
- 'desktop-file-utils' 'hicolor-icon-theme')
+ 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
- 'clang' 'lld' 'gn' 'java-runtime-headless')
+ 'clang' 'lld' 'gn' 'java-runtime-headless')
optdepends=('pepper-flash: support for Flash content'
'kdialog: needed for file dialogs in KDE'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
@@ -27,25 +27,25 @@ optdepends=('pepper-flash: support for Flash content'
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- launch_manager.h-uses-std-vector.patch
- include-algorithm-to-use-std-lower_bound.patch
- icu65.patch
+ cros-search-service-Include-cmath-for-std-pow.patch
+ move-RemoteTreeNode-declaration.patch
sync-enable-USSPasswords-by-default.patch
+ fix-shim-header-generation-when-unbundling-ICU.patch
fix-building-with-system-zlib.patch
- chromium-system-icu.patch
- chromium-system-hb.patch
- fix-spammy-unique-font-matching-log.patch
+ remove-verbose-logging-in-local-unique-font-matching.patch
+ fix-building-with-unbundled-libxml.patch
+ fix-browser-frame-view-not-getting-a-relayout.patch
chromium-skia-harmony.patch)
-sha256sums=('56193431ab9d1193773b133d86b419bfae8d8b9196eea253660895e0e8f87ba0'
+sha256sums=('f51f6fca5d9abbef855aa6b5bf427410c6e96ae58b64a7d45f843868cfb0ac8e'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- 'bd0fae907c451252e91c4cbf1ad301716bc9f8a4644ecc60e9590a64197477d3'
- '1f906676563e866e2b59719679e76e0b2f7f082f48ef0593e86da0351a586c73'
- '1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
+ '0a8d1af2a3734b5f99ea8462940e332db4acee7130fe436ad3e4b7ad133e5ae5'
+ '21f631851cdcb347f40793485b168cb5d0da65ae26ae39ba58d624c66197d0a5'
'08ef82476780e0864b5bf7f20eb19db320e73b9a5d4f595351e12e97dda8746f'
+ 'e477aa48a11ca4d53927f66a9593567fcd053325fb38af30ac3508465f1dd1f6'
'18276e65c68a0c328601b12fefb7e8bfc632346f34b87e64944c9de8c95c5cfa'
- 'e73cc2ee8d3ea35aab18c478d76fdfc68ca4463e1e10306fa1e738c03b3f26b5'
- 'c0ad3fa426cb8fc1a237ddc6309a6b2dd4055bbe41dd07f50071ee61f969b81a'
- '6fbffe59b886195b92c9a55137cef83021c16593f49714acb20023633e3ebb19'
+ '5bc775c0ece84d67855f51b30eadcf96fa8163b416d2036e9f9ba19072f54dfe'
+ 'e530d1b39504c2ab247e16f1602359c484e9e8be4ef6d4824d68b14d29a7f60b'
+ '5db225565336a3d9b9e9f341281680433c0b7bb343dff2698b2acffd86585cbe'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
@@ -94,27 +94,29 @@ prepare() {
sed -i -e 's/\<xmlMalloc\>/malloc/' -e 's/\<xmlFree\>/free/' \
third_party/blink/renderer/core/xml/*.cc \
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
- third_party/libxml/chromium/libxml_utils.cc
+ third_party/libxml/chromium/*.cc
- # https://crbug.com/819294
- patch -Np1 -i ../launch_manager.h-uses-std-vector.patch
- patch -Np1 -i ../include-algorithm-to-use-std-lower_bound.patch
-
- # https://crbug.com/1014272
- patch -Np1 -i ../icu65.patch
+ # https://crbug.com/957519
+ patch -Np1 -i ../cros-search-service-Include-cmath-for-std-pow.patch
+ patch -Np1 -i ../move-RemoteTreeNode-declaration.patch
# https://crbug.com/1027929
patch -Np1 -i ../sync-enable-USSPasswords-by-default.patch
+ # https://crbug.com/989153
+ patch -Np1 -i ../fix-shim-header-generation-when-unbundling-ICU.patch
+
# https://crbug.com/977964
patch -Np1 -i ../fix-building-with-system-zlib.patch
- # Fixes from Gentoo
- patch -Np1 -i ../chromium-system-icu.patch
- patch -Np1 -i ../chromium-system-hb.patch
-
# https://crbug.com/1005508
- patch -Np1 -i ../fix-spammy-unique-font-matching-log.patch
+ patch -Np1 -i ../remove-verbose-logging-in-local-unique-font-matching.patch
+
+ # https://crbug.com/1043042
+ patch -Np1 -i ../fix-building-with-unbundled-libxml.patch
+
+ # https://crbug.com/1046122
+ patch -Np1 -i ../fix-browser-frame-view-not-getting-a-relayout.patch
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch