summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e54cbfef882d..7bdc0a32aeff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-no-extras
-pkgver=87.0.4280.141
-pkgrel=1
+pkgver=88.0.4324.96
+pkgrel=2
_pkgname=chromium
-_launcher_ver=6
-_gcc_patchset=9
+_launcher_ver=7
+_gcc_patchset=3
pkgdesc="Chromium without hangout services, widevine, pipewire, or chromedriver"
arch=('x86_64')
url="https://www.chromium.org/Home"
@@ -17,12 +17,12 @@ license=('BSD')
provides=(chromium=$pkgver)
conflicts=(chromium)
depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
- 'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib'
+ 'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'python2' 'gperf' 'mesa' 'ninja' 'nodejs' 'git' 'libva'
'clang' 'lld' 'gn' 'java-runtime-headless'
'python2-setuptools')
-optdepends=('pepper-flash: support for Flash content'
+optdepends=(
'libva: hardware-accelerated video decode [experimental]'
'kdialog: needed for file dialogs in KDE'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
@@ -30,14 +30,10 @@ optdepends=('pepper-flash: support for Flash content'
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- icu68.patch
- v8-icu68.patch
subpixel-anti-aliasing-in-FreeType-2.8.1.patch)
-sha256sums=('147591d7fc21e1a173701d28bbf35baddb91e64dd96ec16d8eee9a5113403375'
- '04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- 'c99934bcd2f3ae8ea9620f5f59a94338b2cf739647f04c28c8a551d9083fa7e9'
- '38fb5218331d6e03915490dab64f7b8bf26833a581d1aaa02090437c67e9439c'
- '6e919c9712d8fe6c2918778df1f8c2ee0675a87a48be5d2aaa54e320703ced4b'
+sha256sums=('8995c5bb28559579f3bed51841420253637f912c425908fe5aa389ce40e9c79f'
+ '86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
+ 'e5a60a4c9d0544d3321cc241b4c7bd4adb0a885f090c6c6c21581eac8e3b4ba9'
'1e2913e21c491d546e05f9b4edf5a6c7a22d89ed0b36ef692ca6272bcd5faec6')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
@@ -87,13 +83,13 @@ prepare() {
third_party/libxml/chromium/*.cc
# Upstream fixes
- patch -Np1 -i ../icu68.patch
- patch -Np1 -d v8 <../v8-icu68.patch
patch -Np1 -d third_party/skia <../subpixel-anti-aliasing-in-FreeType-2.8.1.patch
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../patches/chromium-87-ServiceWorkerContainerHost-crash.patch
patch -Np1 -i ../patches/chromium-87-openscreen-include.patch
+ patch -Np1 -i ../patches/chromium-88-CompositorFrameReporter-dcheck.patch
+ patch -Np1 -i ../patches/chromium-88-ideographicSpaceCharacter.patch
+ patch -Np1 -i ../patches/chromium-88-AXTreeFormatter-include.patch
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py