summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 903a9f0a3e2a..0c62fa8c5cd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=chromium-no-extras
_pkgname=chromium
-pkgver=100.0.4896.127
+pkgver=101.0.4951.41
pkgrel=1
_launcher_ver=8
_gcc_patchset=4
@@ -33,17 +33,15 @@ options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- webcodecs-stop-using-AudioOpusEncoder.patch
- webrtc-check-existence-of-cursor-metadata.patch
enable-GlobalMediaControlsCastStartStop.patch
+ chromium-libxml-unbundle.patch
sql-make-VirtualCursor-standard-layout-type.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('4710e3453c972c91e68a21f6b0b76ba73d4d617f299a5208615ed6e41b1af84d'
+sha256sums=('099863882e88b9a035fcb6b63dd5288554f6b27558e0ebce93e0d804465efa37'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
- 'a6120e7d4eb5e131b87b6ab3b922e0c6cd78e15501e54cfb2019875173688d80'
- '064daaa2b9d95b96ec04d8ddebf4af441f92263d123365b58fe73966866080af'
- '88b2c8d9c6c1917f6632453f18aad7a3fd94d605eecb6c77ae2394ac5856ba95'
+ '8ed519d21ccd8b382ddd384e9c15306a60d2e3495f48a62dea07c9be9bbffebd'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
+ 'fd3bf124aacc45f2d0a4f1dd86303fa7f2a3d4f4eeaf33854631d6cb39e12485'
'b94b2e88f63cfb7087486508b8139599c89f96d7a4181c61fec4b4e250ca327a'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
@@ -101,13 +99,14 @@ prepare() {
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
# Upstream fixes
- patch -Np1 -i ../webcodecs-stop-using-AudioOpusEncoder.patch
- patch -Np1 -d third_party/webrtc <../webrtc-check-existence-of-cursor-metadata.patch
# Revert kGlobalMediaControlsCastStartStop enabled by default
# https://crbug.com/1314342
patch -Rp1 -F3 -i ../enable-GlobalMediaControlsCastStartStop.patch
+ # https://chromium-review.googlesource.com/c/chromium/src/+/3488058
+ patch -Np1 -i ../chromium-libxml-unbundle.patch
+
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch
@@ -152,6 +151,7 @@ build() {
'clang_use_chrome_plugins=false'
'is_official_build=true' # implies is_cfi=true on x86_64
'symbol_level=0' # sufficient for backtraces on x86(_64)
+ 'chrome_pgo_phase=0' # needs newer clang to read the bundled PGO profile
'treat_warnings_as_errors=false'
'disable_fieldtrial_testing_config=true'
'blink_enable_generated_code_formatting=false'