summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 11 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f00e0c8aed86..64fe5d9a2aa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,10 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-vaapi
-pkgver=89.0.4389.114
-pkgrel=1
+pkgver=90.0.4430.72
+pkgrel=2
_launcher_ver=7
-_gcc_patchset=7
+_gcc_patchset=6
pkgdesc="Chromium with VA-API support to enable hardware acceleration"
arch=('x86_64')
url="https://www.chromium.org/Home"
@@ -32,18 +32,16 @@ conflicts=('chromium')
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- add-dependency-on-opus-in-webcodecs.patch
+ add-clang-nomerge-attribute-to-CheckError.patch
wayland-egl.patch
chromium-glibc-2.33.patch
- chromium-fix-libva-redef.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('f2f0abe9697a220a8545df74d832c6c8d85a4fb11845e7e398752d746e72ed00'
+sha256sums=('a5cc88ca8fffac21ec4d1646980f698dfb6f388a225dd7a2c5a3d252a4098943'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
- 'f8b1558f6c87b33423da854d42f0f69d47885a96d6bf6ce7f26373e93d47442f'
- 'b86b11de8db438c47f0a84c7956740f648d21035f4ee46bfbd50c3348d369121'
+ '3eb9580ea35a96789e02815270498226fa33726f4210a5ee36f3868af2ffae1f'
+ '5e22afcb91b5402bc09e80630c5323d61013c3fccb0bbd9b23d1e79a400b00d0'
'34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
- 'de9eb3612d44616a500c2eccdffac814eb90ad9a868cc1030d17fc6783d544e2'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
@@ -101,15 +99,12 @@ prepare() {
# https://crbug.com/1164975
patch -Np1 -i ../chromium-glibc-2.33.patch
- # https://github.com/kiss-community/repo-community/issues/246
- patch -Np1 -i ../chromium-fix-libva-redef.patch
-
- # Upstream fixes
- patch -Np1 -i ../add-dependency-on-opus-in-webcodecs.patch
+ # Revert addition of [[clang::nomerge]] attribute; not supported by clang 11
+ patch -Rp1 -d base <../add-clang-nomerge-attribute-to-CheckError.patch
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../patches/chromium-89-quiche-dcheck.patch
- patch -Np1 -i ../patches/chromium-89-AXTreeSerializer-include.patch
+ patch -Np1 -i ../patches/chromium-90-quantization_utils-include.patch
+ patch -Np1 -i ../patches/chromium-90-TokenizedOutput-include.patch
# Wayland/EGL regression (crbug #1071528 #1071550)
patch -Np1 -i ../wayland-egl.patch