summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 30 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 049f5468dabb..914069c531ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-vaapi
-pkgver=77.0.3865.120
-pkgrel=2
+pkgver=78.0.3904.70
+pkgrel=1
_launcher_ver=6
pkgdesc="Chromium with VA-API support to enable hardware acceleration"
arch=('x86_64')
@@ -34,24 +34,24 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-drirc-disable-10bpc-color-configs.conf
vaapi-fix.patch
- include-memory-in-one_euro_filter.h.patch
- link-against-harfbuzz-subset.patch
- fix-wrong-string-initialization-in-LinkedHashSet.patch
- include-limits-in-web_time_range.cc.patch
+ add-missing-include-for-unique_ptr.patch
+ dns_util-make-DohUpgradeEntry-non-const.patch
+ fix-shutdown-crash-in-ProfileManager.patch
chromium-system-icu.patch
chromium-system-zlib.patch
+ fix-spammy-unique-font-matching-log.patch
chromium-widevine.patch
chromium-skia-harmony.patch)
-sha256sums=('d792f9b09b1dcfd64e68f47a611c540dd1383dd9abd78ca1e06b2a7e2ff06af8'
+sha256sums=('ddc5794097d65ba19c1ae359c2057b08921e7b38b7afe9d5ec45f5e8b9a87462'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
'7496762a1953b15a48d3e5503fb76d9835940afd850a45b7de976de9f51479f9'
- '33a5bcd1df2cc7aa7467fa882790ef143a4497d2b704c9e1ea86c8ede90c2d90'
- 'ab986e4b723dfcedab1bc8dcada07526facae28a8a7ff3345f658532c1d99987'
- '840f555020751ec284dca35b9317a9dd7dc69fcb910ea1cae2dd7cc9b237dfb7'
- 'd3dfe3c86901a11636972a774ed6c941ac76e38c9e4a384f458043a0a03291a9'
+ '49052e8aa630c4aa57bf46823edc32b7b309493275163c3bb3f9fd390c73356e'
+ '69694ab12a5ced389916c0c5e8c7bdc191544f576b134ddfb2fe9d4ed9ec4494'
+ '4f81612c28957987f7344d8ce2b95a4a63136a8319c9751819436b11c62df057'
'e73cc2ee8d3ea35aab18c478d76fdfc68ca4463e1e10306fa1e738c03b3f26b5'
- '0f7ba6882844542a7226b419dfefc5b6a16b5b7882698bd773b5ee9148aa6e87'
+ 'eb67eda4945a89c3b90473fa8dc20637511ca4dcb58879a8ed6bf403700ca9c8'
+ '6fbffe59b886195b92c9a55137cef83021c16593f49714acb20023633e3ebb19'
'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
@@ -66,8 +66,8 @@ declare -gA _system_libs=(
[icu]=icu
[libdrm]=
[libjpeg]=libjpeg
- #[libpng]=libpng # https://crbug.com/752403#c10
- [libvpx]=libvpx
+ #[libpng]=libpng # https://crbug.com/752403#c10
+ #[libvpx]=libvpx # https://github.com/webmproject/libvpx/commit/5a0242ba5c
[libwebp]=libwebp
[libxml]=libxml2
[libxslt]=libxslt
@@ -106,22 +106,22 @@ prepare() {
# Fix VA-API on Intel and Nvidia
patch -Np1 -i ../vaapi-fix.patch
- # https://crbug.com/819294
- patch -Np1 -i ../include-memory-in-one_euro_filter.h.patch
+ # Missing include in third_party/blink/public/platform/web_rtc_rtp_source.h
+ patch -Np1 -i ../add-missing-include-for-unique_ptr.patch
- # https://groups.google.com/a/chromium.org/d/msg/chromium-packagers/UyJsVJ5QqWo/jSv5z7-rEQAJ
- patch -Np1 -i ../link-against-harfbuzz-subset.patch
+ # https://crbug.com/957519#c23
+ patch -Np1 -i ../dns_util-make-DohUpgradeEntry-non-const.patch
- # https://crbug.com/980025
- patch -Np1 -i ../fix-wrong-string-initialization-in-LinkedHashSet.patch
-
- # https://crbug.com/992832
- patch -Np1 -i ../include-limits-in-web_time_range.cc.patch
+ # https://crbug.com/1005244
+ patch -Np1 -i ../fix-shutdown-crash-in-ProfileManager.patch
# Fixes from Gentoo
patch -Np1 -i ../chromium-system-icu.patch
patch -Np1 -i ../chromium-system-zlib.patch
+ # https://crbug.com/1005508
+ patch -Np1 -i ../fix-spammy-unique-font-matching-log.patch
+
# Load Widevine CDM if available
patch -Np1 -i ../chromium-widevine.patch
@@ -191,14 +191,18 @@ build() {
"google_default_client_secret=\"${_google_default_client_secret}\""
)
+ if check_option strip y; then
+ _flags+=('symbol_level=0')
+ fi
+
# Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)
CFLAGS+=' -Wno-builtin-macro-redefined'
CXXFLAGS+=' -Wno-builtin-macro-redefined'
CPPFLAGS+=' -D__DATE__= -D__TIME__= -D__TIMESTAMP__='
- if check_option strip y; then
- _flags+=('symbol_level=0')
- fi
+ # Do not warn about unknown warning options
+ CFLAGS+=' -Wno-unknown-warning-option'
+ CXXFLAGS+=' -Wno-unknown-warning-option'
gn gen out/Release --args="${_flags[*]}" --script-executable=/usr/bin/python2
ninja -C out/Release chrome chrome_sandbox chromedriver