summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c31ac5d8737b..1e84b1d557a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Simon Legner <Simon.Legner@gmail.com
+
pkgname=cht.sh-git
-pkgver=r586.c4c3a62
-pkgrel=2
+pkgver=r819.d2b8697
+pkgrel=1
pkgdesc="The only cheat sheet you need (command line client for cheat.sh)"
arch=('any')
url='https://github.com/chubin/cheat.sh'
license=('MIT')
+provides=('cht.sh')
+conflicts=('cht.sh')
depends=('curl' 'xsel' 'rlwrap')
makedepends=('git')
-source=("$pkgname::git+https://github.com/chubin/cheat.sh")
-sha1sums=('SKIP')
-conflicts=('cht.sh')
+source=("${pkgname}::git+https://github.com/chubin/cheat.sh")
+sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$pkgname"
+ cd "${pkgname}"
install -Dm755 "share/cht.sh.txt" "$pkgdir/usr/bin/cht.sh"
install -Dm644 "share/bash_completion.txt" "$pkgdir/usr/share/bash-completion/completions/cht.sh"
install -Dm644 "share/fish.txt" "$pkgdir/usr/share/fish/vendor_completions.d/cht.sh.fish"
install -Dm644 "share/zsh.txt" "$pkgdir/usr/share/zsh/site-functions/_cht.sh"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}