summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4d841216cb0..60da34de9218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
pkgname=cinnamon-session-git
-pkgver=4.0.0
+pkgver=4.4.1.r1.ga582be4
pkgrel=1
pkgdesc="The Cinnamon Session Handler"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ url="https://github.com/linuxmint/${pkgname%-git}"
license=('GPL' 'LGPL')
depends=('cinnamon-desktop' 'dbus-glib' 'libsm' 'libcanberra' 'xapps')
optdepends=('cinnamon-translations: i18n')
-makedepends=('git' 'meson' 'xtrans')
+makedepends=('git' 'meson' 'samurai' 'xtrans')
provides=("${pkgname%-git}=${pkgver}")
conflicts=("${pkgname%-git}")
source=("git+${url}.git")
@@ -30,14 +30,14 @@ build() {
meson --prefix=/usr \
--libexecdir=lib/${pkgname%-git} \
--buildtype=plain \
- -Dwith-gconf=false \
- -Dwith-docbook=false \
+ -Dgconf=false \
+ -Ddocbook=false \
..
- ninja
+ samu
}
package() {
cd "${srcdir}"/${pkgname%-git}/build
- DESTDIR="${pkgdir}" ninja install
+ DESTDIR="${pkgdir}" samu install
}