summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78bafe40112c..815f11b6a82a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,24 @@
# Maintainer: mibbio <contact at mibbiodev dot de>
_name='Ciliora-Prima'
-pkgname=cinnamon-theme-${_name,,}
-pkgver=20151229
+pkgname=cinnamon-theme-${_name,,}-git
+pkgver=r69.5f66d27
pkgrel=1
pkgdesc="${_name} theme for Cinnamon 2.8"
arch=('any')
-url="http://cinnamon-spices.linuxmint.com/themes/view/323"
+url="https://github.com/zagortenay333/${_name,,}-cinnamon"
license=('GPL')
depends=('cinnamon>=2.8.0' 'cinnamon<2.9.0')
-source=("http://cinnamon-spices.linuxmint.com/uploads/themes/7D8E-9P4O-VC17.zip")
-sha256sums=('b7e2ffd43dceab611ddee2cc522a247b0f9892b2c6a5119565087e567959c1fa')
+replaces=("cinnamon-theme-${_name,,}")
+source=("git+https://github.com/zagortenay333/${_name,,}-cinnamon")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_name,,}-cinnamon"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- find ${_name} -type f -not -name *~ -not -name *.sh -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/{}" \;
+ cd "$srcdir/${_name,,}-cinnamon"
+ find ${_name} -type f -not -name *~ -not -name *.sh -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/{}" \;
}