summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae8088f7842e..ecd6bcae92ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=citra
pkgname=$_pkgname-canary-git
-pkgver=2698.r0.g24ccdfa
+pkgver=2703.r0.g094fd0f
pkgrel=1
pkgdesc='An experimental open-source Nintendo 3DS emulator/debugger'
arch=('i686' 'x86_64')
@@ -22,7 +22,7 @@ fi
provides=("citra" "citra-qt" "citra-canary" "citra-git" "citra-qt-git")
conflicts=("citra" "citra-qt" "citra-canary" "citra-git" "citra-qt-git")
license=('GPL2')
-depends=('sdl2' 'mbedtls' 'speexdsp' 'qt6-multimedia' 'ffmpeg' 'libfdk-aac' 'libusb' 'openssl' 'glibc' 'gcc-libs' 'sndio' 'libbacktrace-git' 'zstd' 'soundtouch' 'fmt' 'libinih')
+depends=('sdl2' 'mbedtls' 'speexdsp' 'qt6-multimedia' 'ffmpeg' 'libfdk-aac' 'libusb' 'openssl' 'glibc' 'gcc-libs' 'sndio' 'libbacktrace-git' 'zstd' 'soundtouch' 'fmt' 'libinih' 'openal')
makedepends=('git' 'cmake' 'python' 'doxygen' 'rapidjson' 'llvm' 'qt6-tools' 'gcc' 'glslang' 'vulkan-headers' 'nlohmann-json')
source=("$_pkgname::git+https://github.com/citra-emu/citra-canary.git"
"boost::git+https://github.com/citra-emu/ext-boost.git"
@@ -165,8 +165,10 @@ build() {
-DUSE_SYSTEM_SDL2=ON \
-DUSE_SYSTEM_JSON=ON \
-DUSE_SYSTEM_LIBUSB=ON \
+ -DUSE_SYSTEM_OPENAL=ON \
+ -DUSE_SYSTEM_OPENSSL=ON \
+ -DUSE_SYSTEM_VULKAN_HEADERS=ON \
-DUSE_SYSTEM_SOUNDTOUCH=ON \
- -DUSE_SYSTEM_GLSLANG=OFF \
-DUSE_SYSTEM_INIH=ON \
-DUSE_SYSTEM_ZSTD=ON \
-DCMAKE_C_COMPILER=gcc \