summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e8beee9ad68..95b095947be3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: openfbt
# Contributor: Werecat
# Contributor: Xyne
_pkgname=cjdns
pkgname=$_pkgname-git
-pkgver=21.1.r38.g20ddc268
+pkgver=22.r7.g2faa4c83
pkgrel=1
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
@@ -13,7 +14,7 @@ license=('GPL3')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
options=('!distcc' '!strip' '!buildflags')
depends=('bash')
-makedepends=('git' 'nodejs' 'python2' 'binutils' 'llvm')
+makedepends=('cargo' 'git' 'nodejs' 'python' 'binutils' 'llvm')
optdepends=(
'cjdnsify: allows you to run some programs bound to your cjdns address'
@@ -22,7 +23,7 @@ optdepends=(
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+$url#branch=crashey")
+source=("git+$url#branch=master")
sha512sums=('SKIP')
pkgver() {
@@ -32,8 +33,7 @@ pkgver() {
build() {
cd $_pkgname
- bash 'do'
-
+ CJDNS_RELEASE_VERSION="${pkgver}" ./do
}
package() {