summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7c54dd23e6d..8b95cdf3dc66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,20 @@
# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
pkgname=cjdnsify
-pkgver=20140717.r6.bc354af
-pkgrel=2
+pkgver=1.0
+epoch=1
+pkgrel=1
pkgdesc='Limit network access of bind-compatible programs to the local cjdns network'
url='https://github.com/prurigro/cjdnsify'
license=('GPL')
depends=('bash' 'cjdns' 'force_bind')
-makedepends=('git')
arch=('any')
backup=("etc/default/$pkgname")
-source=("git://github.com/prurigro/$pkgname.git")
-sha512sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+source=("https://github.com/prurigro/cjdnsify/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('4711b9bfdb17d3afd341c115dea4a6bf5f3095f0c2de51c8e7ac9d9f26900c532ae663b7581519ebfa74fd5ea41981cc8bdc3cabb01f7f25da116f780b911e77')
package() {
- cd $pkgname
+ cd $pkgname-$pkgver
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm644 $pkgname.conf "$pkgdir/etc/default/$pkgname"
}