summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fa086902523..5ff0e36abc5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: alzeih <alzeih@users.noreply.github.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
pkgname=cjose
-pkgver=0.6.1
+pkgver=0.6.2.3
pkgrel=1
-pkgdesc="C library implementing the Javascript Object Signing and Encryption (JOSE)"
-arch=('x86_64')
-url="https://github.com/cisco/cjose"
-license=('MIT')
-depends=('openssl' 'jansson')
-makedepends=('jansson')
-source=("https://github.com/cisco/$pkgname/archive/$pkgver.tar.gz")
-sha512sums=('7ae67a6d19591b3d19b888270ec0ca17df399bea117e42686fc1de39b3741ed9a8816f96d33d090687c49c3123cdc95430a781835a525a02d22561ebf5aaa653')
+pkgdesc='C library implementing the Javascript Object Signing and Encryption (JOSE)'
+arch=(x86_64)
+url="https://github.com/OpenIDC/$pkgname"
+license=(MIT)
+depends=(openssl
+ jansson)
+_archive="$pkgname-$pkgver"
+source=("$url/releases/download/v$pkgver/$_archive.tar.gz")
+sha256sums=('2c5f930ddcb09be7db04ab6ffb679b20aa5f24f4fc26f47cc63bc01c19c9fe11')
build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+ cd "$_archive"
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_archive"
+ make DESTDIR="$pkgdir" install
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}