summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 5 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0902f8f87c63..77bf4fdf33b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Patrik Plihal <patrik.plihal@gmail.com>
pkgname=ckan-git
-pkgver=1.18.0.r5.g0ab70f4
+pkgver=1.22.3.r0.g64309722
pkgrel=1
pkgdesc="A metadata repository and associated tools for searching, installing, and managing mods for Kerbal Space Program (KSP)"
arch=('any')
@@ -13,52 +13,20 @@ provides=('ckan')
conflicts=('ckan')
depends=('mono' 'curl')
makedepends=('git' 'python2' 'python2-requests')
-source=('git://github.com/KSP-CKAN/CKAN'
- 'disable_version_checks.diff')
-sha256sums=('SKIP'
- '21ed582d41da7f52ea4014fdcfadcadb7025f0fbae924fccd345c3b1f0fbff44')
+source=('git://github.com/KSP-CKAN/CKAN')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/CKAN"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
-
- # ignore certain version checks that return "inconclusive" exceptions for development builds
- cd "$srcdir/CKAN/"
- git apply $srcdir/disable_version_checks.diff
-}
-
build() {
cd "$srcdir/CKAN"
- xbuild /verbosity:minimal CKAN.sln
-
- cd "$srcdir/CKAN/Cmdline"
- mono ../Core/packages/ILRepack.1.25.0/tools/ILRepack.exe \
- /target:exe \
- /out:$srcdir/ckan.exe \
- bin/Debug/CmdLine.exe \
- bin/Debug/CKAN-GUI.exe \
- bin/Debug/ChinhDo.Transactions.dll \
- bin/Debug/CKAN.dll \
- bin/Debug/CommandLine.dll \
- bin/Debug/ICSharpCode.SharpZipLib.dll \
- bin/Debug/log4net.dll \
- bin/Debug/Newtonsoft.Json.dll \
- bin/Debug/INIFileParser.dll \
- bin/Debug/CurlSharp.dll \
- bin/Debug/Autofac.dll
-}
-
-check() {
- #nunit-console4 is included in mono
-
- cd "$srcdir/CKAN/"
- command nunit-console4 --exclude=FlakyNetwork Tests/bin/Debug/CKAN.Tests.dll
+ ./build
}
package() {
mkdir -p "$pkgdir/usr/bin/"
- cp $srcdir/ckan.exe "$pkgdir/usr/bin/ckan"
+ cp $srcdir/CKAN/_build/ckan.exe "$pkgdir/usr/bin/ckan"
}