summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57a25a66be03..e36d966e592d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=clash-meta
pkgver=1.17.0
-pkgrel=3
+pkgrel=6
pkgdesc="Another Clash Kernel by MetaCubeX"
arch=('x86_64' 'aarch64' 'riscv64' 'loong64')
url="https://github.com/MetaCubeX/Clash.Meta"
@@ -16,13 +16,12 @@ source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz
"clash-meta@.service"
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
- "config.yaml")
+)
sha256sums=('0c6f2c073189211aaa5a6ce8019f1c3f421bc4cdc1e46217a0a76912c6a38927'
'b6b7ce11489a6f6322a41ce840b3f999b1ec88914f8bd6864c220269231bf759'
'ec4de877464e595124a5f2752c3f4be157adc85ec5f7f8392c0331cb70fc906a'
'655e8e2edcd82a6bdf2fd12430b7ab6f8e32db8dffce70e7342685a7cc65ebfb'
- '50737592c7bd743fe8f543924034718337477a203fa11ef4272cae496df3769c'
- '90f7fdacecd5928e37865b4f841517f925c8bedc769f16f7a7a1e89b923f1fb9')
+ '50737592c7bd743fe8f543924034718337477a203fa11ef4272cae496df3769c')
prepare(){
cd "${srcdir}"
@@ -39,19 +38,19 @@ build(){
-buildmode=pie \
-mod=readonly \
-modcacherw \
- -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" \
- -X \"github.com/Dreamacro/clash/constant.Version=${pkgver}\" \
- -X \"github.com/Dreamacro/clash/constant.BuildTime=${BUILDTIME}\" \
+ -ldflags "-linkmode external -extldflags '${LDFLAGS}' \
+ -X 'github.com/metacubex/mihomo/constant.Version=${pkgver}' \
+ -X 'github.com/metacubex/mihomo/constant.BuildTime=${BUILDTIME}' \
" \
-tags with_gvisor -o ${pkgname}-${pkgver}
}
package() {
cd "${srcdir}"/Clash.Meta-${pkgver}
install -Dm755 "${pkgname}-${pkgver}" "${pkgdir}/usr/bin/clash-meta"
+ install -Dm644 "docs/config.yaml" -t "${pkgdir}/etc/clash-meta"
cd $srcdir
install -Dm644 ${pkgname}.sysusers "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
install -Dm644 ${pkgname}.tmpfiles "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
- install -Dm644 "config.yaml" -t "${pkgdir}/etc/clash-meta"
install -Dm644 "clash-meta.service" -t "${pkgdir}/usr/lib/systemd/system"
install -Dm644 "clash-meta@.service" -t "${pkgdir}/usr/lib/systemd/system"
ln -sf /etc/clash/Country.mmdb ${pkgdir}/etc/${pkgname}/Country.mmdb