aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6f2a5290a8e..dcb6af2a9de4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tang Yuming <felinae225@qq.com>
pkgname=clashup
-pkgver=0.2.6
-pkgrel=1
+pkgver=0.3.0
+pkgrel=2
pkgdesc="auto update clash's config file"
license=('GPL')
arch=('any')
@@ -10,10 +10,14 @@ depends=(python
clash
python-requests
python-daemon)
-source=(clashup clashup.conf)
+source=(clashup clashup.conf clashup.service clashup.timer)
package() {
install -Dm755 clashup ${pkgdir}/usr/bin/clashup
install -Dm644 clashup.conf ${pkgdir}/etc/systemd/user/clash.service.d/clashup.conf
+ install -Dm644 clashup.service ${pkgdir}/usr/lib/systemd/system/clashup.service
+ install -Dm644 clashup.timer ${pkgdir}/usr/lib/systemd/system/clashup.timer
}
-md5sums=('5003219768c527792b83b9412097c4c5'
- '177338346005e11d33e27edc1f8ab780')
+md5sums=('d2d6b7c638bd59e6ac0cfd1ece1301e1'
+ '177338346005e11d33e27edc1f8ab780'
+ 'f805be578902fb8c6606aef828111af8'
+ '58604e2d881d0260623659ce06158e14')