summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD129
1 files changed, 58 insertions, 71 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51a972455644..adc865aa0490 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,44 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=claws-mail-git
-pkgver=3.17.4.r0.g215b6adc8
+pkgver=4.1.1.r1.g1e3b95e1d
pkgrel=1
pkgdesc='A GTK+ based e-mail client - git checkout'
arch=('i686' 'x86_64')
license=('GPL3')
url='https://www.claws-mail.org/'
-depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'compface'
- 'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('git' 'spamassassin' 'bogofilter' 'valgrind'
- # dependencies for plugins
- 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk' 'dillo' 'gumbo-parser'
- # deps to build the docs
- 'docbook-utils' 'texlive-core' 'texlive-formatsextra')
-optdepends=('python2: needed for some tools and python plugin'
- 'perl: needed for some tools and perl plugin'
- 'spamassassin: adds support for spamfiltering'
- 'bogofilter: adds support for spamfiltering'
- 'libnotify: for notification plugin'
- 'libcanberra: for notification plugin'
- 'dbus: for notification plugin'
- 'libxml2: for rssyl plugins'
- 'curl: for vcalendar, rssyl and spamreport plugins'
- 'libarchive: for archive plugin and various other plugins'
- 'libytnef: for tnef_parse plugin'
- 'libgdata: for gdata plugin'
- 'poppler-glib: for pdf viewer plugin'
- 'ghostscript: for pdf viewer plugin'
- 'gumbo-parser: for litehtml_viewer plugin'
- 'dillo: for dillo html viewer plugin')
-replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
-conflicts=('claws-mail-extra-plugins' 'claws-mail')
+depends=('gtk3' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
+ 'libetpan' 'compface' 'libsm' 'dbus-glib')
+makedepends=('git' 'spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
+ # dependencies for plugins
+ 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
+ 'dillo' 'python' 'gumbo-parser'
+ # deps to build the docs
+ 'docbook-utils' 'texlive-formatsextra' 'lynx')
+optdepends=('python: needed for some tools'
+ 'perl: needed for some tools and perl plugin'
+ 'spamassassin: adds support for spamfiltering'
+ 'bogofilter: adds support for spamfiltering'
+ 'libnotify: for notification plugin'
+ 'libcanberra: for notification plugin'
+ 'dbus: for notification plugin'
+ 'libxml2: for rssyl plugins'
+ 'curl: for vcalendar, rssyl and spamreport plugins'
+ 'libarchive: for archive plugin and various other plugins'
+ 'libytnef: for tnef_parse plugin'
+ 'libgdata: for gdata plugin'
+ 'poppler-glib: for pdf viewer plugin'
+ 'ghostscript: for pdf viewer plugin'
+ 'libical: for vcalendar plugin'
+ 'dillo: for dillo html viewer plugin'
+ 'webkit2gtk: for fancy webkit html viewer plugin'
+ 'gumbo-parser: for litehtml plugin')
+conflicts=('claws-mail')
provides=('claws' 'claws-mail')
-source=('claws-mail::git://git.claws-mail.org/claws.git')
-sha256sums=('SKIP')
+source=('claws-mail::git://git.claws-mail.org/claws.git'
+ 'bash_completion')
+sha256sums=('SKIP'
+ '3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
pkgver() {
cd claws-mail/
@@ -52,59 +56,42 @@ pkgver() {
}
prepare() {
- cd claws-mail/
+ cd claws-mail/
- # fixes for python2
- sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
- git update-index --assume-unchanged tools/*.py
+ # run autogen without options
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd claws-mail/
-
- # run autogen without options - it runs ./configure for us, but we need to fix python first
- NOCONFIGURE=1 ./autogen.sh
+ cd claws-mail/
- # fixes for python2
- export PYTHON="/usr/bin/python2"
- sed -i 's:python -c:python2 -c:g' configure
+ ./configure --prefix=/usr --disable-static \
+ --enable-enchant \
+ --enable-gnutls \
+ --enable-ldap \
+ --enable-crash-dialog \
+ --enable-pgpmime-plugin \
+ --enable-spamassassin-plugin \
+ --enable-bogofilter-plugin \
+ --enable-fancy-plugin \
+ --enable-manual
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
- # add --enable-alternate-addressbook to the options to use the
- # new/alternate address book
- # do not forget to add claws-contacts to the dependencies then
- ./configure \
- --prefix=/usr \
- --disable-jpilot \
- --disable-maintainer-mode \
- --disable-manual \
- --disable-static \
- --enable-bogofilter-plugin \
- --enable-crash-dialog \
- --enable-enchant \
- --enable-gnutls \
- --enable-ldap \
- --enable-litehtml_viewer-plugin \
- --enable-pgpmime-plugin \
- --enable-silent-rules \
- --enable-spamassassin-plugin
- #--help
- make
-
- # build extra tools
- cd tools/
- make
}
package() {
- cd claws-mail/
+ cd claws-mail/
+
+ make DESTDIR="${pkgdir}" install
- make DESTDIR="${pkgdir}" install
+ install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
- # install extra tools
- # all executables and .conf files ; only top directory
- cd tools
- for FILE in $(find -maxdepth 1 -type f -and -perm /111 -or -name '*.conf'); do
- install -D -m0755 ${FILE} "${pkgdir}"/usr/lib/claws-mail/tools/${FILE}
- done
+ # install extra tools
+ cd tools
+ install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
+ for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
+ cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/
+ done
}