summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 17 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec7feadc0e58..3898dc1c0ffa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jacob Henner <code@ventricle.us>
+# Maintainer: zan <zan@420blaze.it>
+# Contributor: Jacob Henner <code@ventricle.us>
# Contributor: Eduardo Sánchez Muñoz
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
@@ -8,41 +9,35 @@
# Based on community/clementine PKGBUILD
pkgname=clementine-git
-pkgver=1.3.1.r963.gfb51e7733
+pkgver=1.4.0rc1.r296.g68d375c43.0.g68d375c43
pkgrel=1
pkgdesc='A modern music player and library organizer'
url='http://www.clementine-player.org/'
-license=('GPL')
-arch=('i686' 'x86_64')
-depends=('crypto++' 'chromaprint' 'desktop-file-utils' 'glew' 'gst-plugins-base-libs' 'libmygpo-qt5' 'protobuf' 'qt5-x11extras')
-makedepends=('boost' 'cmake' 'git')
+license=(GPL)
+arch=(x86_64)
+depends=(chromaprint glew gst-plugins-base-libs libmygpo-qt5 protobuf qt5-x11extras)
+makedepends=(boost cmake git)
optdepends=('libcdio: for CD support'
- 'libgpod: for iPhone and iPod Touch support'
- 'liblastfm-qt5: for LastFM support'
- 'libmtp: for MTP support')
-conflicts=('clementine')
-provides=('clementine')
-replaces=('clementine-qt5-git')
+ 'libgpod: for iPhone and iPod Touch support'
+ 'liblastfm-qt5: for LastFM support'
+ 'libmtp: for MTP support'
+ 'crypto++: for Spotify plugin')
+conflicts=(clementine)
+provides=(clementine)
_name=Clementine
source=("git+https://github.com/clementine-player/$_name.git")
sha256sums=('SKIP')
pkgver() {
- cd $srcdir/$_name
+ cd $_name
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- mkdir -p "$srcdir/build"
- cd "$srcdir/build"
- cmake "$srcdir/$_name" \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_SPOTIFY_BLOB=off
- make
+ cmake -B build -S $_name -DENABLE_SPOTIFY_BLOB=off
+ cmake --build build
}
package() {
- cd "$srcdir/build"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}