summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3898dc1c0ffa..95a5be7109f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,14 +25,21 @@ optdepends=('libcdio: for CD support'
conflicts=(clementine)
provides=(clementine)
_name=Clementine
-source=("git+https://github.com/clementine-player/$_name.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/clementine-player/$_name.git"
+ "close-fix.diff")
+sha256sums=('SKIP'
+ '587c3724483825c2101fc15b8ef3b04b15a4dee34457285f94da6dd9b6db656c')
pkgver() {
cd $_name
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $_name
+ patch -p1 -i $srcdir/close-fix.diff
+}
+
build() {
cmake -B build -S $_name -DENABLE_SPOTIFY_BLOB=off
cmake --build build