summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6e445f5a5b0..ca52299dc5a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Maintainer: Dmitry Bilunov <kmeaw@yandex-team.ru>
pkgname=clickhouse
-pkgver=1.1.54236
+pkgver=1.1.54242
pkgrel=1
pkgdesc='An open-source column-oriented database management system that allows generating analytical data reports in real time'
arch=('i686' 'x86_64')
url='https://clickhouse.yandex/'
license=('Apache')
depends=('ncurses' 'readline' 'unixodbc' 'termcap')
-makedepends=('poco' 'cmake' 'gcc6')
+makedepends=('poco' 'cmake' 'gcc63')
source=(https://github.com/yandex/ClickHouse/archive/v$pkgver-stable.tar.gz
clickhouse-server.service
re2-length.patch)
-md5sums=('78083caddfdc9b2fead32d11ea8609b8'
+md5sums=('71554342277b2a91cc15ecf92a61c3ab'
'f9f5663b0a9a58e99f481efe9d193e85'
'143f0146c3ef3a6832191fba352b70c4')
backup=('etc/clickhouse-client/config.xml' 'etc/clickhouse-server/config.xml' 'etc/clickhouse-server/users.xml')
@@ -23,8 +23,8 @@ build() {
cd ClickHouse-$pkgver-stable
sed -e 's/mysqlxx common\(.*\) \(\${Z_LIB}\)/mysqlxx \2 common\1/' -i libs/libmysqlxx/CMakeLists.txt
patch -p1 < ../re2-length.patch
- export CC=gcc-6
- export CXX=g++-6
+ export CC=gcc-6.3
+ export CXX=g++-6.3
cmake -D CMAKE_BUILD_TYPE:STRING=Release -D USE_STATIC_LIBRARIES:BOOL=False -D ENABLE_TESTS:BOOL=False -D UNBUNDLED:BOOL=False .
make clickhouse
}