summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdefdb097be8..44f0bff7900d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Dmitry Bilunov <kmeaw@yandex-team.ru>
pkgname=clickhouse
-pkgver=1.1.54276
+pkgver=1.1.54292
pkgrel=1
pkgdesc='An open-source column-oriented database management system that allows generating analytical data reports in real time'
arch=('i686' 'x86_64')
@@ -12,17 +12,24 @@ depends=('ncurses' 'readline' 'unixodbc' 'termcap')
makedepends=('poco' 'cmake')
source=(https://github.com/yandex/ClickHouse/archive/v$pkgver-stable.tar.gz
clickhouse-server.service
- re2-length.patch)
-md5sums=('62f37ed7c09f2f11f277550d255e606f'
+ re2-length.patch
+ libunwind.patch)
+md5sums=('68825ce6a1ef9842289d42c0f1015592'
'f9f5663b0a9a58e99f481efe9d193e85'
- '143f0146c3ef3a6832191fba352b70c4')
+ '143f0146c3ef3a6832191fba352b70c4'
+ 'f3f60b75abf8d6f21de74db6e88e1e7b')
backup=('etc/clickhouse-client/config.xml' 'etc/clickhouse-server/config.xml' 'etc/clickhouse-server/users.xml')
install=$pkgname.install
-build() {
+prepare() {
cd ClickHouse-$pkgver-stable
sed -e 's/mysqlxx common\(.*\) \(\${Z_LIB}\)/mysqlxx \2 common\1/' -i libs/libmysqlxx/CMakeLists.txt
patch -p1 < ../re2-length.patch
+ patch -p1 < ../libunwind.patch
+}
+
+build() {
+ cd ClickHouse-$pkgver-stable
cmake -D CMAKE_BUILD_TYPE:STRING=Release -D USE_STATIC_LIBRARIES:BOOL=False -D ENABLE_TESTS:BOOL=False -D UNBUNDLED:BOOL=False .
make clickhouse
}