summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db99beed2834..f4ac0446cf69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=clifm-git
pkgver=0.27.1
-pkgrel=2
-pkgdesc="The KISS file manager: cli-based, ultra-lightweight, and lightning fast (development version)"
+pkgrel=3
+pkgdesc="The KISS file manager: cli-based, ultra-lightweight, and lightning fast"
arch=(any)
url="https://github.com/leo-arch/clifm"
license=(GPL2)
@@ -13,6 +13,11 @@ optdepends=('sshfs: SFTP support' 'cifs-utils: Samba support' 'curlftpfs: FTPFS
source=("git+${url}.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname%%-*}"
+ curl -s "https://raw.githubusercontent.com/leo-arch/${pkgname%%-*}/master/${pkgname%%-*}.c" | grep "#define VERSION" | cut -d" " -f3 | sed 's/"//g'
+}
+
build() {
cd "$srcdir/${pkgname%%-*}"
gcc -O3 -march=native -s -fstack-protector-strong -o "${pkgname%%-*}" "${pkgname%%-*}.c" -lreadline -lacl -lcap