summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 850622687796..49b9cbfa9f4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutantota dot com>
# Contributor: Federico Di Pierro <nierro92@gmail.com>
pkgname=clight
-pkgver=4.9
+pkgver=4.10
pkgrel=1
pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms."
arch=('x86_64' 'aarch64')
@@ -14,16 +14,16 @@ optdepends=('geoclue: to retrieve user location through geoclue.'
and to autocalibrate keyboard backlight.'
'bash-completion: to add support for bash automatic completion.'
'clight-gui: Clight GUI written in Qt.')
-backup=("etc/default/$pkgname.conf")
+backup=("etc/$pkgname/$pkgname.conf"
+ "etc/$pkgname/modules.conf.d"/{backlight,daytime,dimmer,dpms,gamma,inhibit,keyboard,screen,sensor}.conf)
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('638696ee22a3a3340659db37d4e3c6fc2763eee9c8c2f7f227190ad9db7742db')
+sha256sums=('fa385472d3b055f94875930873fafbb225d4874793755bd3ec2bba6ef1b85871')
build() {
cmake -B build -S Clight-$pkgver \
- -G "Unix Makefiles" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
-Wno-dev
cmake --build build
}