summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f90c751b42a..7576d167acc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,11 +12,17 @@ license=('MIT')
depends=('lua' 'python')
makedepends=('clang' 'cmake' 'git' 'ninja' 're2c')
conflicts=('clasp')
-source=("git+https://github.com/potassco/clingo#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("git+https://github.com/potassco/clingo#tag=v${pkgver}"
+ "python38-fix.patch")
+sha256sums=('SKIP'
+ '782d9fa710e59cba36bc3bfb922d52de0469cd3d0c5c591308f8e459139bd72f')
prepare() {
sed '/#include <xlocale.h>/d' -i "${srcdir}"/clingo/clasp/libpotassco/src/string_convert.cpp
+
+ cd "${srcdir}/${pkgname}"
+ # Upstream patch
+ patch -Np1 -i "${srcdir}/python38-fix.patch"
}
build() {