summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a76d17cf6660
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=clipto-bin
+pkgver=2.4.6
+pkgrel=1
+pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
+arch=('x86_64')
+url="https://clipto.pro"
+license=('custom')
+depends=('nss' 'libxss' 'libxtst' 'libappindicator-gtk3' 'libnotify')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}.pro")
+replaces=("${pkgname%-bin}.pro")
+source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
+ "${pkgname%-bin}")
+sha256sums=('9d0dea1830dff1fcb4a25689c49cf3e309c8d408da21087d28810b734664ff12'
+ 'a68ea565595fca737ff54b7a29e04f5059e5897955ab15c09ca9f36eb70fcfdb')
+
+prepare() {
+ chmod +x "${pkgname%-bin}-$pkgver.AppImage"
+ ./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
+
+ sed -i 's|Exec=AppRun|Exec=/opt/clipto/clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
+}
+
+package() {
+ find squashfs-root/{locales,resources,usr/share/icons}/ -type d -exec chmod 755 {} +
+
+ install -d "$pkgdir/opt/${pkgname%-bin}"
+ cp -r squashfs-root/* "$pkgdir/opt/${pkgname%-bin}"
+ rm -rf "$pkgdir/opt/${pkgname%-bin}/usr"
+ rm "$pkgdir/opt/${pkgname%-bin}"/{"${pkgname%-bin}".desktop,AppRun}
+
+ install -Dm755 "${pkgname%-bin}" -t "$pkgdir/usr/bin"
+
+ install -Dm644 "squashfs-root/${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications"
+
+ install -d "$pkgdir/usr/share/icons"
+ cp -r squashfs-root/usr/share/icons/hicolor "$pkgdir/usr/share/icons"
+}