summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 22 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 220b03f3506b..7368ce1695b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,48 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=clipto-bin
pkgver=7.2.17
-pkgrel=11
-_electronversion=21
+pkgrel=12
pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
arch=('x86_64')
url="https://clipto.pro"
license=('custom')
-depends=("electron${_electronversion}")
+depends=('alsa-lib' 'gtk3' 'nss')
+optdepends=('libnotify: for desktop notifications'
+ 'libappindicator-gtk3: for tray icon')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}" "${pkgname%-bin}.pro")
replaces=("${pkgname%-bin}.pro")
-source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
- "${pkgname%-bin}")
-sha256sums=('ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028'
- '7c299ef6dfa822911c2facd564b1459a7564be07a6e89875f0fca1d357374ec4')
+source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage")
+sha256sums=('ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028')
prepare() {
chmod +x "${pkgname%-bin}-$pkgver.AppImage"
./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
+ # Correct path for .desktop file
sed -i 's|Exec=AppRun|Exec=clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
+
+ # Remove X-AppImage-Version
+ sed -i '/AppImage/d' "squashfs-root/${pkgname%-bin}.desktop"
+
+ # Remove invalid symlink
+ rm squashfs-root/clipto.png
}
package() {
cd "$srcdir/squashfs-root"
find {locales,resources,usr/share/icons}/ -type d -exec chmod 755 {} +
- install -d "$pkgdir/usr/lib/${pkgname%-bin}"
- cp -r resources "$pkgdir/usr/lib/${pkgname%-bin}"
+ install -d "$pkgdir/opt/${pkgname%-bin}"
+ cp -r * "$pkgdir/opt/${pkgname%-bin}/"
- install -Dm755 "$srcdir/${pkgname%-bin}" -t "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/${pkgname%-bin}/${pkgname%-bin}" -t "$pkgdir/usr/bin/"
- install -Dm644 "${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications/"
install -d "$pkgdir/usr/share/icons"
- cp -r usr/share/icons/hicolor "$pkgdir/usr/share/icons"
+ cp -r usr/share/icons/hicolor "$pkgdir/usr/share/icons/"
+
+ rm -rf "$pkgdir/opt/${pkgname%-bin}/usr/"
}