summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 15 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e5fb9ca1f87..95e9daf52cf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=cliqz
_pkgname=browser-f
-pkgver=1.16.3
+pkgver=1.17.0
pkgrel=1
-_cqzbuildid=20171109085129
+_cqzbuildid=20171127205425
pkgdesc="Firefox-based privacy aware web browser, build from sources"
arch=(i686 x86_64)
url="https://cliqz.com/"
@@ -17,16 +17,13 @@ source=("https://github.com/cliqz-oss/browser-f/archive/${pkgver}.tar.gz"
wifi-disentangle.patch
wifi-fix-interface.patch
no-plt.diff
- plugin-crash.diff
- glibc-2.26-fix.diff
- 0001-Bug-1384062-Make-SystemResourceMonitor.stop-more-res.patch)
-sha256sums=('657eec637ded9b3144e7bdc5e1adddfeaf1180e4f82d5297ce8ac8fba7baeb7b'
+ 0001-Bug-1360278-Add-preference-to-trigger-context-menu-o.patch)
+sha256sums=('11aec82033c9deea31e109108f553f4c87a089cba318aff19f32a0f091e237ff'
'f068b84ad31556095145d8fefc012dd3d1458948533ed3fff6cbc7250b6e73ed'
'e98a3453d803cc7ddcb81a7dc83f883230dd8591bdf936fc5a868428979ed1f1'
'ea8e1b871c0f1dd29cdea1b1a2e7f47bf4713e2ae7b947ec832dba7dfcc67daa'
- 'a7e5d2430bb562f6367deb07417dad4368317e8e8be5d1cfa842c3356de3cfc0'
- 'cd7ff441da66a287f8712e60cdc9e216c30355d521051e2eaae28a66d81915e8'
- 'aba767995ffb1a55345e30aaba667f43d469e23bd9b1b68263cf71b8118acc96')
+ '1f71b379f2262d7319624c2aed31fa2dbed42828feccc27b1cd82153b76ad707')
+
options=(!emptydirs !makeflags !strip)
prepare() {
@@ -47,24 +44,16 @@ Name[fr]=Nouvelle fenêtre en mode oubli
Exec=/usr/lib/cliqz/cliqz --private-window %u
END
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1360278
+ patch -Np1 -i $srcdir/0001-Bug-1360278-Add-preference-to-trigger-context-menu-o.patch
+
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -Np1 -i $srcdir/wifi-disentangle.patch
patch -Np1 -i $srcdir/wifi-fix-interface.patch
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1384062
- patch -Np1 -i $srcdir/0001-Bug-1384062-Make-SystemResourceMonitor.stop-more-res.patch
-
# https://bugzilla.mozilla.org/show_bug.cgi?id=1382942
patch -Np1 -i $srcdir/no-plt.diff
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1400175
- patch -Np1 -i $srcdir/plugin-crash.diff
-
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1385667
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1394149
- patch -Np1 -i $srcdir/glibc-2.26-fix.diff
-
-
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
@@ -83,7 +72,7 @@ END
ac_add_options --prefix=/usr
ac_add_options --enable-gold
ac_add_options --enable-pie
-ac_add_options --enable-optimize="-O2"
+ac_add_options --enable-rust-simd
# System libraries
ac_add_options --with-system-zlib
@@ -95,7 +84,6 @@ ac_add_options --enable-system-ffi
# Features
ac_add_options --enable-startup-notification
ac_add_options --disable-updater
-ac_add_options --disable-stylo
STRIP_FLAGS="--strip-debug"
END
@@ -107,7 +95,11 @@ build() {
# Hardening
LDFLAGS+=" -Wl,-z,now"
- CPPFLAGS+=" -O2"
+ # Avoid duplicate compilation options
+ march=$(gcc -Q --help=target | grep march | sed -nr 's/^.*\s+([^\s]+)$/\1/p')
+ CFLAGS="-march=${march} -mtune=generic -O2 -fstack-protector-strong -fno-plt"
+ CPPFLAGS="-D_FORTIFY_SOURCE=2"
+ CXXFLAGS="-march=${march} -mtune=generic -fstack-protector-strong -fno-plt"
export CQZ_RELEASE_CHANNEL=release
export CQZ_VERSION=$pkgver