summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79543f156c75..9e0ad6955f8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=cliqz
_pkgname=browser-f
-pkgver=1.22.0
+pkgver=1.22.2
pkgrel=1
_cqzbuildid=$(curl "http://repository.cliqz.com.s3.amazonaws.com/dist/release/$pkgver/lastbuildid")
pkgdesc="Firefox-based privacy aware web browser, build from sources"
@@ -10,13 +10,11 @@ url="https://cliqz.com/"
license=(MPL2)
depends=(gtk2 gtk3 libxt startup-notification dbus-glib nss libvpx libevent
hunspell hunspell-en_US)
-makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
+makedepends=(unzip zip diffutils python2 yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm libnotify gtk2 gtk3 wget pulseaudio)
conflicts=(cliqz-bin)
-source=("https://github.com/cliqz-oss/browser-f/archive/$pkgver.tar.gz"
- init.configure.patch)
-sha256sums=('bcb598df874ba5c3fd904ea4f33b05600037062eed33a12899af1f96bda1245f'
- '531ced6caeb57877e2b39d7aeb2eba3c03e15a1aaa5a27df3391e59b7d592549')
+source=("https://github.com/cliqz-oss/browser-f/archive/$pkgver.tar.gz")
+sha256sums=('176abb4290f9009ee93797c7ad810146cc497660396f6bd45cb6c33d398d37a4')
options=(!emptydirs !makeflags !strip)
prepare() {
@@ -29,9 +27,6 @@ prepare() {
sed -i "s/@MOZ_APP_NAME@/$pkgname/g" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
sed -i "s|^Exec=${pkgname}$|Exec=/usr/lib/${pkgname}/${pkgname} %u|" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
- # rust.configure problem
- patch build/moz.configure/init.configure ../../init.configure.patch
-
cat >> toolkit/mozapps/installer/linux/rpm/mozilla.desktop <<END
Actions=new-forget-window;
@@ -94,6 +89,7 @@ ac_add_options --enable-system-ffi
# Features
ac_add_options --enable-startup-notification
ac_add_options --disable-updater
+ac_add_options --disable-gconf
END
# Symbols are build only for windows. Have them back now