summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95535be69fd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: David Harrigan <dharrigan [@] gmail [dot] com>
+
+pkgname=cljstyle-bin
+pkgver=0.11.1
+pkgrel=1
+pkgdesc='A tool for formatting Clojure code'
+arch=('x86_64')
+url='https://github.com/greglook/cljstyle'
+license=('EPL')
+provides=('cljstyle')
+conflicts=('cljstyle')
+
+source=("https://github.com/greglook/cljstyle/releases/download/${pkgver}/${pkgname/\-bin/}_${pkgver/_/-}_linux.tar.gz")
+
+sha256sums=('690b408fbabfc8e838544a5438c3d6dbf456962be410a4c858697c48ae8dc9b4')
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname/\-bin/}" "${pkgdir}/usr/bin/${pkgname/\-bin/}"
+}