summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 24 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11bdcfbb9dce..9ce9a1e2f5f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
-# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+# Contributor: Aaron Fischer <mail@aaron-fischer.net>
# Contributor: Allan McRae <allan@archlinux.org>
pkgname=cloog
-pkgver=0.20.0
-pkgrel=2
+pkgver=0.21.1
+pkgrel=1
pkgdesc="Library that generates loops for scanning polyhedra"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.bastoul.net/cloog/"
license=('GPL')
-depends=('osl' 'libisl')
-makedepends=('texlive-core' 'texlive-bin')
-source=(https://github.com/periscop/cloog/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
-sha512sums=('d00cbefd348b45d9d482320a088f7ae736440046b99469cbdfbb177a38dcef182c3305f0a567a1f5699c23b7108db6fd5ad6dfbc071d63ccca1d6bfc1b198565')
+depends=('osl' 'libisl' 'gmp')
+makedepends=('texlive-core' 'texlive-bin' 'texlive-plaingeneric')
+source=("https://github.com/periscop/cloog/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('bfb76bc69941ba0ddd81f1d52d807c02cd24e5baf3d8b774148712494e256709531e4ceb0402309ed2596a2a3ee951dc6bcc4e21502199942e2bd9dab705c9f2')
+
+_srcdir="${pkgname}-${pkgver}"
+
+prepare() {
+ cd "${_srcdir}"
+ sed -i 's/OSL_CPPFLAGS+="/OSL_CPPFLAGS="$OSL_CPPFLAGS/' 'configure'
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --with-isl=system --with-osl=system
- make
+ cd "${_srcdir}"
+ ./configure --prefix=/usr --with-cloog-int=gmp --with-isl=system --with-osl=system --with-osl-prefix=/usr
+ make
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # There are certain race conditions on running the tests, so we restrict
- # it to one job (one CPU core).
+ cd "${_srcdir}"
+ # There are certain race conditions on running the tests, so we restrict
+ # it to one job (one CPU core).
- make -j1 check
+ make -j1 check
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR=$pkgdir/ install
+ cd "${_srcdir}"
+ DESTDIR="$pkgdir" make install
}