summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f622d12eee1b..586a70dccd95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,34 @@
-# Maintainer: AbrarSyed <aur@abrarsyed.com>
+# Maintainer: AbrarSyed <aur _AT_ abrarsyed _DOT_ com>
pkgname=cloudfoundry-cli
-pkgver=7.1.0
+pkgver=8.7.10
pkgrel=1
pkgdesc="The official command line client for Cloud Foundry"
arch=('x86_64')
url="https://github.com/cloudfoundry/cli"
license=('Apache')
-provides=()
+provides=(cf)
options=('!emptydirs' '!strip')
-source=("cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel")
+source=(
+ "cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel"
+ "cf-cli-completion::https://raw.githubusercontent.com/cloudfoundry/cli-ci/master/ci/installers/completion/cf"
+)
-md5sums=('05b5a4e37f347556be97444e27ad01ac')
-sha256sums=('53f93b3a940566cb1fddfc24f2b3c60528b2516c200c553bd30e0d1e99a09723')
-sha512sums=('a454df6aac8010e0c241eef96dcf3668a5ecac31a1ca1a34b2b1a17038abda3dd7856cccf2c72d2fab4970114681e11b22aa04242d60abd3af225025a5d4f7aa')
+md5sums=('5da640f16fec9c37deb7a3c842ae1006'
+ 'b3dc7a45905e0dc58f3011f431befb90')
+sha256sums=('3ecb1cf3d677aa314f6cb638518dc01832426b4f60f795dee648aa78c8bdc480'
+ 'f3f05a2414075c00b101b05f73cf260b9eec9966659adf2957c1b2937bd4c48e')
+sha512sums=('b37a5314f22f42e005c0e9082fcc00775b287c6829c52cc045821a360ec99093c1d52b0fffb570e208bd41ba38ae6b568d1ddc2d23528dfe57743153834fcee6'
+ '016e999430d8c78ed06eb283f31ed601d6d6fb5ee2da9253f84e2364a13fe1723dfd9501f6bf53019ef6f1b54eb8e094e11564ed3d154a475a43321a99d080ef')
package() {
# copy binary
mkdir -p "$pkgdir/usr/bin"
- install $srcdir/cf "$pkgdir/usr/bin"
+ install $srcdir/cf8 "$pkgdir/usr/bin"
+ ln -s /usr/bin/cf8 "$pkgdir/usr/bin/cf"
+
+ # copy completion file, ripped from Pappy's CF6 PKGBUILD
+ install -Dm644 cf-cli-completion $pkgdir/usr/share/bash-completion/completions/cf
#copy license & notice
mkdir -p "$pkgdir/usr/share/doc/cf-cli"