summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00da9e8bd620..ecdd78290e0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,34 @@
-# Maintainer: AbrarSyed <aur@abrarsyed.com>
+# Maintainer: AbrarSyed <aur _AT_ abrarsyed _DOT_ com>
pkgname=cloudfoundry-cli
-pkgver=7.4.0
+pkgver=8.3.0
pkgrel=1
pkgdesc="The official command line client for Cloud Foundry"
arch=('x86_64')
url="https://github.com/cloudfoundry/cli"
license=('Apache')
-provides=()
+provides=(cf)
options=('!emptydirs' '!strip')
-source=("cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel")
+source=(
+ "cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel"
+ "cf-cli-completion::https://raw.githubusercontent.com/cloudfoundry/cli-ci/master/ci/installers/completion/cf"
+)
-md5sums=('a66ceec6a5aec43de5d283799acc1022')
-sha256sums=('6ac44598c580fe24c98f3b52df2e6357116478c68dee5c74800cb39cba421695')
-sha512sums=('966b5afa7b0bcba1e2dd2035d7311de2a6e56a68aa768a0e9020fe51e7a1932f2e29ec59f6959dfd3e48a6ab3b2945bd049a0b68b2c269097813157df0b98d1e')
+md5sums=('aa3d07847b4081d03ff1bc162f7cbe6d'
+ 'b3dc7a45905e0dc58f3011f431befb90')
+sha256sums=('5d2e9b1ef129a84a63f2fc6c429146c7b23ea8dba172a8b1c6f1cb1c8867eb0e'
+ 'f3f05a2414075c00b101b05f73cf260b9eec9966659adf2957c1b2937bd4c48e')
+sha512sums=('229dab36d1fdaadad933761c0ea7de2fafde66492be9b6b10018c7cf0d45428a42298a1ecfcc1a9052d5dc1633e26658eba01116becf63631fb23cdccacc80e6'
+ '016e999430d8c78ed06eb283f31ed601d6d6fb5ee2da9253f84e2364a13fe1723dfd9501f6bf53019ef6f1b54eb8e094e11564ed3d154a475a43321a99d080ef')
package() {
# copy binary
mkdir -p "$pkgdir/usr/bin"
- install $srcdir/cf "$pkgdir/usr/bin"
+ install $srcdir/cf8 "$pkgdir/usr/bin"
+ ln -s /usr/bin/cf8 "$pkgdir/usr/bin/cf"
+
+ # copy completion file, ripped from Pappy's CF6 PKGBUILD
+ install -Dm644 cf-cli-completion $pkgdir/usr/share/bash-completion/completions/cf
#copy license & notice
mkdir -p "$pkgdir/usr/share/doc/cf-cli"