summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5274b5de58f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='cloudlist'
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Tool for listing Assets from multiple Cloud Providers'
+arch=('x86_64' 'armv6h' 'aarch64')
+url='https://github.com/projectdiscovery/cloudlist'
+license=('MIT')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('8ea13a80755e059bf38ca96e40012161cf6101567e9ae0f18cbf6c70b2810534')
+
+prepare() {
+ export GOPATH="${srcdir}/gopath"
+ go clean -modcache
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "${pkgname}-${pkgver}"
+ go build -v -o "${pkgname}" ."/cmd/${pkgname}"
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dvm755 "${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: