summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45e5ce2929b0..526c7d517603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,16 @@
# This PKGBUILD is based on the official Arch cmake package.
pkgname=cmake-git
-pkgver=3.27.0.rc4.205.gff3179cef8
-pkgrel=2
+pkgver=3.27.4.645.g72beefa91b
+pkgrel=1
pkgdesc='A cross-platform open-source make system'
arch=('x86_64')
url="http://www.cmake.org/"
license=('custom')
conflicts=('cmake')
provides=('cmake')
-depends=('curl' 'libarchive' 'hicolor-icon-theme' 'jsoncpp' 'libjsoncpp.so' 'libuv' 'rhash')
-makedepends=('qt6-base' 'python-sphinx' 'emacs' 'git')
+depends=('curl' 'libarchive' 'hicolor-icon-theme' 'jsoncpp' 'libjsoncpp.so' 'libuv' 'rhash' 'cppdap')
+makedepends=('qt6-base' 'python-sphinx' 'emacs' 'nlohmann-json' 'git')
optdepends=('qt6-base: cmake-gui')
source=('git+https://gitlab.kitware.com/cmake/cmake.git'
'cmake-cppflags.patch')
@@ -48,7 +48,6 @@ build() {
--sphinx-html \
--system-libs \
--qt-gui \
- --no-system-cppdap \
--parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN)
make
}